www.cendio.com
Bug 5054 - server .desktop files are not installed on ubuntu
: server .desktop files are not installed on ubuntu
Status: CLOSED FIXED
: ThinLinc
Other
: trunk
: PC Unknown
: P2 Normal
: 4.2.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2014-03-28 14:45 by
Modified: 2014-04-09 15:24 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2014-03-28 14:45:00
Seen on Ubuntu 14.04 Beta 2.

The .desktop files for tl-setup, tlwebadm and tlwebaccess are never installed
as they should. Installing tlclient results in a proper .desktop file though,
which is odd because the post-install script is more or less identical.
------- Comment #1 From cendio 2014-04-02 13:39:18 -------
Actually they got installed, but to /usr/share/gnome instead.

The problem is that xdg-desktop-menu will install things into the first
writeable directory in $XDG_DATA_DIRS, and ubuntu changes this variable
depending on how you log in.

We should probably do unset on all XDG variables before running the xdg tools.
------- Comment #2 From cendio 2014-04-02 16:42:30 -------
Fixed in r28795.
------- Comment #3 From cendio 2014-04-09 15:24:08 -------
Verified using build 4318, works as expected.