www.cendio.com
Bug 5062 - trigger scripts in deb and solaris packages are not run properly
: trigger scripts in deb and solaris packages are not run properly
Status: CLOSED FIXED
: ThinLinc
Other
: trunk
: PC Unknown
: P2 Normal
: 4.2.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2014-04-02 11:10 by
Modified: 2014-05-05 15:50 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2014-04-02 11:10:39
The different scripts we have in our deb packages (postinst, prerm, etc.) are
not run properly and therefore do not behave correctly under some
circumstances. The problem is that they are converted from their RPM
equivalents, but RPM and deb have different arguments for the scripts.

One prominent example is the preun/prerm script which fail to clean up icons
and desktop files on Debian based systems.


One general way of solving this is to have our RPM-to-deb converter inject some
magical converter code at the start of each script, that converts the argument
list.
------- Comment #1 From cendio 2014-04-02 15:48:28 -------
Same problem with solaris.
------- Comment #2 From cendio 2014-04-02 16:23:18 -------
Fixed in r28792 and r28793.

Tester should verify that scripts are run on:

 - Fresh installation.

 - Upgrade.

 - Removal.
------- Comment #3 From cendio 2014-04-07 12:28:01 -------
Tested on Ubuntu 13.10 using build 4313. Works as intended. A bug #5071 was
created due to pyc files preventing the remove of directories.
------- Comment #4 From cendio 2014-04-14 14:21:02 -------
I've verified that tlwebaccess runs its postinstall and preremove scripts on
package installation, so the general approach seems to work just fine.

(4.1.1post-4323)