www.cendio.com
Bug 5090 - Linux client installation modifies defaults.list, which contains configuration about default applications
: Linux client installation modifies defaults.list, which contains configuratio...
Status: CLOSED FIXED
: ThinLinc
Client platforms
: 4.1.1
: PC Linux
: P2 Normal
: 4.10.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2014-04-14 13:10 by
Modified: 2019-01-03 17:24 (History)
Acceptance Criteria:
* The Linux client package should not modify any "defaults.list".


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2014-04-14 13:10:21
Thinlinc clienconf mime type is still registered after an uninstall of the
thinlinc client.

$ xdg-mime query default  application/vnd.cendio.thinlinc.clientconf
thinlinc-client.desktop
------- Comment #1 From cendio 2014-04-14 13:32:44 -------
https://bugs.freedesktop.org/show_bug.cgi?id=71825
------- Comment #2 From cendio 2018-12-05 09:32:14 -------
Due to the work done on bug 7183, we are no longer using xdg-desktop-menu, and
we are no longer updating /usr/local/share/applications/defaults.list.

As far as I understand it, it's not necessary to update this file when only one
application provides a certain mime type. Some people also regard this file as
obsolete, see:
https://lists.freedesktop.org/archives/xdg/2014-February/013183.html

I've tested client uninstall (build 5976) at Ubuntu 18.10 and the problem is no
longer present.
------- Comment #3 From cendio 2018-12-05 15:49:08 -------
Our conclusion is that it is actually incorrect for an application to touch
defaults.list during installation; this file should be regarded as system
administrator preferences.

Note that we will not try to undo changes done by old clients.
------- Comment #4 From cendio 2019-01-03 17:24:56 -------
I tested the ThinLinc Client on Ubuntu 14.04, SLES 15 and Fedora 29. I verified
the following:

* After installing the nightly ThinLinc Client it will properly be associated
with .tlclient files in "Files" and nautilus

* Uninstalling the nightly ThinLinc Client removes this association

Seems to work well. Note that bug 7301 was found while testing this.