www.cendio.com
Bug 5183 - Resizing the ThinLinc client window while a SeamlessRDP application is running sometimes causes the rdesktop window to remain visible.
: Resizing the ThinLinc client window while a SeamlessRDP application is runnin...
Status: CLOSED FIXED
: ThinLinc
| WTS Tools (deprecated)
: trunk
: PC Unknown
: P2 Normal
: 4.3.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2014-06-10 12:59 by
Modified: 2014-10-09 08:57 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2014-06-10 12:59:14
Version:
ThinLinc 4.2.0 (with rdesktop version thinlinc-rdesktop-4.2.0post-4375).

Operating System:
SUSE Linux Enterprise Server 11 SP3 (VSM Server and Agent) and Windows Server
2008 R2 (Windows App Server).

Environment:
Standard GNOME Desktop profile, with desktop customization.

Steps to reproduce:

 1. Login to a ThinLinc session with ThinLinc client (make sure the
    "Resize remote session to local window" option is active);

 2. Select profile;

 3. Start seamless RDP application (Notepad, for example) either through
    desktop icon or by typing "tl-run-winapp-seamless notepad.exe" on a 
    terminal;

 4. Resize the ThinLinc client window (either using the mouse or by exiting 
    fullscreen with the F8 menu).

Expected behavior:
 The session desktop should resize to the client window size, the SeamlessRDP  
 session should reconnect (resizing the SeamlessRDP area), and the running  
 Windows applications should remain as before eg. not show the RDP session 
 background as described below.

Actual behavior:
 Sometimes, the session desktop resizes to the client window size and the 
 remote desktop window becomes visible eg. not seamless.
------- Comment #1 From cendio 2014-06-10 13:00:15 -------
When this happens, one of two error messages appear on the "xinit.log" file:

· "WARNING: SeamlessRDP: Invalid request:ACK,2143,33HELLO,2147,0x00000003";

· "WARNING: SeamlessRDP: Invalid
request:DESTROYGRP,0,0x000005d0,0x00000000HELLO,2088,0x00000003".

After resizing the ThinLinc client window again, the SeamlessRDP session
reconnects and it returns to the normal state, seamless is activated.
------- Comment #3 From cendio 2014-07-02 10:25:53 -------
This is now fixed in upstream commit 1820.
------- Comment #4 From cendio 2014-07-02 10:33:28 -------
Fix brought to ctc in vendordrop commit 29148.
------- Comment #5 From cendio 2014-10-09 08:57:14 -------
Looks good. Not able to reproduce the problem on windows 2008 r2 with build
4506.