Bug 5205 - Numeric keys are not resolved as KP_x symbols within a ThinLinc session.
Summary: Numeric keys are not resolved as KP_x symbols within a ThinLinc session.
Status: CLOSED DUPLICATE of bug 400
Alias: None
Product: ThinLinc
Classification: Unclassified
Component: VNC (show other bugs)
Version: 4.2.0
Hardware: PC Unknown
: P2 Normal
Target Milestone: 4.9.0
Assignee: Pierre Ossman
URL:
Keywords:
Depends on:
Blocks: 3523
  Show dependency treegraph
 
Reported: 2014-07-01 14:39 CEST by Henrik Andersson
Modified: 2018-04-23 13:34 CEST (History)
0 users

See Also:
Acceptance Criteria:


Attachments

Description Henrik Andersson cendio 2014-07-01 14:39:59 CEST
After some investigation it seems like KP_x symbols are sent but resolves into standard number symbols server side.
Comment 1 Henrik Andersson cendio 2014-07-01 16:40:34 CEST
I found this is Xvnc source code:

	/*
	 * X11 generally lets shift toggle the keys on the numeric pad
	 * the same way NumLock does. This is however not the case on
	 * other systems like Windows. As a result, some applications
	 * get confused when we do a fake shift to get the same effect
	 * that having NumLock active would produce.
	 *
	 * Until we have proper NumLock synchronisation (so we can
	 * avoid faking shift), we try to avoid the fake shifts if we
	 * can use an alternative keysym.
	 */

And there is a configuration param that toggles this behavior on/off. With other words it is possible to turn on the fake shift numkey by adding argument '-AvoidShiftNumLock=0'. An KP_x event will produced using a fake shift numkey.
Comment 2 Henrik Andersson cendio 2014-07-02 07:51:51 CEST
The reason behind this is that VNC doesn't do numlock sync, see bug #400.
Comment 3 Pierre Ossman cendio 2014-07-03 14:54:15 CEST
Relevant upstream commit:

https://github.com/TigerVNC/tigervnc/commit/1753a93da571479a0cc1a90261376d2eb8350890
Comment 4 Pierre Ossman cendio 2018-04-23 13:34:26 CEST

*** This bug has been marked as a duplicate of bug 400 ***

Note You need to log in before you can comment on or make changes to this bug.