www.cendio.com
Bug 5265 - Provide a tool to run a command with the ThinLinc environment variables
: Provide a tool to run a command with the ThinLinc environment variables
Status: CLOSED FIXED
: ThinLinc
Misc
: 4.2.0
: PC Unknown
: P2 Normal
: 4.3.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2014-09-22 08:40 by
Modified: 2014-10-06 16:28 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2014-09-22 08:40:55
A partial solution for bug 1685 is to provide a tool which only deals with the
environment. In 4.3.0, we will save the environment to
${TLSESSIONDATA}/xstartup.env. What's missing is a tool which can execute a
command in this environment. We also need to deal with the problem that,
currently, xstartup.env is created from the "env" output, which does not
correctly handle environment variables which contains embedded newlines etc.
------- Comment #1 From cendio 2014-09-22 08:45:10 -------
Implemented in 29388.
------- Comment #2 From cendio 2014-09-22 09:29:22 -------
Documented and tweaked in r29389, r29390. 

Suggested test cases:

* Check that xstartup.env is created. Contents should be what "env -0"
produces. 

* tl-notify 

* Executing a command outside the session: tl-env -d xterm
------- Comment #3 From cendio 2014-09-29 11:13:17 -------
Verified using ThinLinc build 4505, works as expected.

However tl-notify have double meaning error reporting when xstartup.env is
removed from session directory;

/opt/thinlinc/sbin/tl-notify hello
error: failed to read xstartup.env ([Errno 2] No such file or directory:
'/var/opt/thinlinc/sessions/cendio/1/xstartup.env')
Message sent to 1 sessions on this agent.
------- Comment #4 From cendio 2014-09-29 11:20:51 -------
(In reply to comment #3)
> Verified using ThinLinc build 4505, works as expected.
> 
> However tl-notify have double meaning error reporting when xstartup.env is
> removed from session directory;
> 
> /opt/thinlinc/sbin/tl-notify hello
> error: failed to read xstartup.env ([Errno 2] No such file or directory:
> '/var/opt/thinlinc/sessions/cendio/1/xstartup.env')
> Message sent to 1 sessions on this agent.

Should be a problem introduced by bug 5153.
------- Comment #5 From cendio 2014-09-29 13:38:41 -------
(In reply to comment #4)
> Should be a problem introduced by bug 5153.

Closing due to the issue is handled on bug #5153