www.cendio.com
Bug 5290 - Resizing to make the the rdp session larger doesn't work on windows 2012 and later
: Resizing to make the the rdp session larger doesn't work on windows 2012 and ...
Status: CLOSED FIXED
: ThinLinc
| rdesktop (deprecated)
: trunk
: PC Unknown
: P2 Normal
: 4.9.0
Assigned To:
:
:
:
: 6096
  Show dependency treegraph
 
Reported: 2014-10-09 16:08 by
Modified: 2017-10-02 10:11 (History)
Acceptance Criteria:


Attachments
Video showing the issue (3.89 MB, video/webm)
2014-10-14 11:05, Samuel Mannehed
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2014-10-09 16:08:37
When resizing sometimes the new parts of the screen becomes black. Seems to
only happen when resizing to a bigger resolution than before. The windows
desktop is resized but it seems like rdesktop isn't getting updates for the
increased area. Mouse clicks work in the black areas.

When this happens it seems like the background image breaks as well (the
background becomes black).

Happens on both Windows 2012 R2 Server and 2012 non-R2 Server.

Does not happen on Windows 2008 R2 Server.
------- Comment #2 From cendio 2014-10-14 11:05:25 -------
Created an attachment (id=576) [details]
Video showing the issue
------- Comment #3 From cendio 2015-09-15 14:38:37 -------
This [1] upstream commit, might fix this bug. Reason being that on a resize the
clipping window is not reset to the new window size.

[1] https://github.com/rdesktop/rdesktop/commit/c843a3
------- Comment #4 From cendio 2016-10-31 10:03:07 -------
*** Bug 6072 has been marked as a duplicate of this bug. ***
------- Comment #5 From cendio 2016-10-31 10:20:37 -------
(In reply to comment #3)
> This [1] upstream commit, might fix this bug. Reason being that on a resize the
> clipping window is not reset to the new window size.
> 
> [1] https://github.com/rdesktop/rdesktop/commit/c843a3

Unfortunately, this doesn't help.
------- Comment #6 From cendio 2016-10-31 10:26:55 -------
The bug is consistently reproducible when trying to increase the size of the
session:

1. Login to a Windows 2012 session using ThinLinc and "rdesktop -f"
2. Resize the window to make it bigger
3. The new area which was added is black and does not get updates

---

Have tested 2012r2 without updates, fully updated and with several states in
between these two, this bug is not related to Windows Updates.

The bug exists with rdesktop upstream, with rdesktop in ThinLinc 4.7.0 and with
rdesktop in ThinLinc 4.2.0.

Moving from 'MediumPrio' to '---' for discussion.
------- Comment #7 From cendio 2017-05-11 09:12:17 -------
A user of rdesktop also found this bug and made a patch, see
https://github.com/rdesktop/rdesktop/issues/117
------- Comment #8 From cendio 2017-05-15 15:02:56 -------
Investigate a bit in this issue due to the upstream report. A fix is
committed upstream (05689db) and it works good. Tested using ThinLinc
and Windows 2012r2 server.
------- Comment #9 From cendio 2017-09-05 07:37:58 -------
This is also seen on Windows 2016 while testing it to be supported. I haven't
tested the mentioned fix upstream in comment #8.
------- Comment #10 From cendio 2017-09-05 09:40:37 -------
I did a test using rdesktop from upstream which includes the mentioned fix in
comment #8 agains Windows 2016, which solves the problem with the broken
resize.
------- Comment #11 From cendio 2017-09-26 12:47:07 -------
Fixed via vendor drop in r32760.
------- Comment #13 From cendio 2017-09-26 17:08:49 -------
Verified that the problem is fixed on Windows 2008 R2 and Windows 2016. Will
also test 2012.
------- Comment #14 From cendio 2017-10-02 10:11:45 -------
Verified that the problem is fixed on Windows 2012 R2.