www.cendio.com
Bug 5304 - tl-memberof-group should perhaps support more than one group argument
: tl-memberof-group should perhaps support more than one group argument
Status: CLOSED FIXED
: ThinLinc
Misc
: 4.2.0
: PC Unknown
: P2 Normal
: 4.4.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2014-10-15 08:53 by
Modified: 2015-03-20 10:29 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2014-10-15 08:53:04
Currently, tl-memberof-group only accepts a single group argument. It could be
useful to be able to specify multiple groups. Of course, in this case we need
to decide if the command should return true only if the user is a member of all
those groups, or any of those groups. If believe the latter is best. That would
also follow how TLDC works.
------- Comment #1 From cendio 2014-10-15 08:54:06 -------
*** Bug 3543 has been marked as a duplicate of this bug. ***
------- Comment #4 From cendio 2015-03-04 11:13:35 -------
r30087.
------- Comment #5 From cendio 2015-03-05 13:44:54 -------
Tweaked in 30101.
------- Comment #6 From cendio 2015-03-17 13:32:09 -------
Verfied functionality using build 4691 and it works as expected;

One can now specify several groups to check against and misspelled groups are
clearly reported to stderr.