www.cendio.com
Bug 5405 - SLE 12 is missing LSB support
: SLE 12 is missing LSB support
Status: CLOSED FIXED
: ThinLinc
Server OS
: 4.3.0
: PC Unknown
: P2 Normal
: 4.4.0
Assigned To:
:
:
: 5403 5436
: 5437
  Show dependency treegraph
 
Reported: 2015-01-26 12:06 by
Modified: 2015-05-11 10:32 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2015-01-26 12:06:47
If we choose to recommend SLE12 we need to remove the installation of LSB frmo
tl-setup.
------- Comment #1 From cendio 2015-02-17 09:51:52 -------
Investigate whether a minimal installation of SLE12 has everything we need for
ThinLinc - i.e. is there anything that we need that LSB used to bring in that
isn't already installed on a minimal SLE12?
------- Comment #2 From cendio 2015-02-18 13:50:23 -------
The SLE12 installer has groups of packages that it calls "Patterns". You can
achieve varying levels of minimal installation using these:

 - Nothing checked
 - Minimal system
 - Base system

Each step seems to include the previous one. It also has a disclaimer that
"Minimal system" is unsupported unless you have an OEM agreement and that Base
is the normal minimum you must install.

Just to be sure though, we'll try to support even the most minimal of these
three (nothing checked).
------- Comment #3 From cendio 2015-02-18 13:52:25 -------
LSB 4.1 Core requires these libraries:

 - libc
 - libm
 - libpthread
 - libgcc_s
 - libdl
 - librt
 - libcrypt
 - libpam
 - libz
 - libncurses
 - libutil
 - libnspr4
 - libnss3
 - libssl3

All are present except for the NSS/NSPR ones (libnspr4, libnss3, libssl3).
------- Comment #4 From cendio 2015-02-18 14:03:24 -------
LSB 4.1 Desktop requires:

 - libX11
 - libSM
 - libICE
 - libXt
 - libXext
 - libXi
 - libXtst
 - libGL
 - libGLU
 - libpng12
 - libjpeg
 - libfontconfig
 - libfreetype
 - libXft
 - libXrender
 - libcairo
 - libglib-2.0
 - libgobject-2.0
 - libgmodule-2.0
 - libgthread-2.0
 - libatk-1.0
 - libpango-1.0
 - libpangocairo-1.0
 - libpangoxft-1.0
 - libpangoft2-1.0
 - libgdk_pixbuf-2.0
 - libgdk-x11-2.0
 - libgtk-x11-2.0
 - libQtCore
 - libQtGui
 - libQtXml
 - libQtOpenGL
 - libQtSql
 - libQtSvg
 - libQtNetwork
 - libqt-mt
 - libxml2
 - libasound

These are not present:

 - libXi
 - libXtst
 - libGL
 - libGLU
 - libpng12 (libpng16 instead)
 - libjpeg
 - libfontconfig
 - libXft
 - libXrender
 - libcairo
 - libgthread-2.0
 - libatk-1.0
 - libpango-1.0
 - libpangocairo-1.0
 - libpangoxft-1.0
 - libpangoft2-1.0
 - libgdk_pixbuf-2.0
 - libgdk-x11-2.0
 - libgtk-x11-2.0
 - libQtCore
 - libQtGui
 - libQtXml
 - libQtOpenGL
 - libQtSql
 - libQtSvg
 - libQtNetwork
 - libqt-mt
 - libasound

Noteworthy is that most of glib2 is installed, just not libgthread.
------- Comment #5 From cendio 2015-02-18 14:04:06 -------
Note that I have not checked that the above libraries provide the proper
symbols, only if they exist or not.
------- Comment #6 From cendio 2015-02-18 14:15:20 -------
The libraries that we currently use in the server are:

 - libc
 - libm
 - libpthread
 - libdl
 - librt
 - libcrypt
 - libpam
 - libz
 - libX11
 - libresolv
 - libpcsclite
 - libglib-2.0
 - libgthread-2.0

libresolv is not in LSB, but it is present so it's safe. libpcsclite is also
not in LSB, but we provide our own so it is also safe. It is only a problem if
LD_LIBRARY_PATH is modified, and in that case we have problems on other
distributions as well.

The problem is libgthread-2.0 which is used by pcsctun and it is missing on the
minimal SLES12 install. It is however present if you choose the X11 "pattern",
but "Base" is still insufficient.
------- Comment #7 From cendio 2015-02-26 11:00:09 -------
Fixed in r30046. We will only look for and install libgthread on SLE 12+.

Tested on SLES12 in bare bone installation, and on SLED11 to make sure there
were no regressions.
------- Comment #8 From cendio 2015-05-11 10:32:43 -------
Looks good. Verified that tl-setup works on both SLED 11 sp3 and SLES 12.