www.cendio.com
Bug 5423 - performance issue with our libjpeg
: performance issue with our libjpeg
Status: CLOSED FIXED
: ThinLinc
Build system
: pre-1.0
: PC Unknown
: P2 Normal
: 4.4.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2015-02-05 14:28 by
Modified: 2015-05-06 14:32 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2015-02-05 14:28:23
Whilst investigating bug 5242 I discovered that there is a performance issue
with our libjpeg compared to Fedora 21's.

Decoding the file googleearth-rgb-24.rfb takes 1.45 seconds with a static
build, and 1.04 with a dynamic build (i.e. using Fedora's libraries). gprof on
the static build shows that almost all the time is spent inside libjpeg, so I
doubt it's one of the other libraries that affects things.
------- Comment #1 From cendio 2015-02-05 16:35:05 -------
Apparently we weren't building libjpeg with -O2 which is the cause of the
performance difference. Should be easy enough to fix.

I'll be upgrading to 1.4.0 at the same time though as I already tested that to
see if it was the version difference that caused problems.
------- Comment #2 From cendio 2015-02-05 17:31:37 -------
Fixed by doing bug 4929. Upgrade in r29941 (by accident).
------- Comment #3 From cendio 2015-05-06 11:27:33 -------
I have tried to record a rfb stream using rfbproxy etc. but I have no idea how
to continue doing a test as described.

Can the someone write down steps to produce a rfb file and how to
decode/playback and measure the performance.
------- Comment #4 From cendio 2015-05-06 11:30:55 -------
Testing during normal usage is sufficient. We don't ship the raw test tools.
------- Comment #5 From cendio 2015-05-06 14:32:14 -------
Verified that building of libjpeg package is using -O2 flag and that the
upgrade to 1.4.0 didn't introduced any artifacts or other problems.

I just averaged cpu usage from top with following result:

fc21 - 14.6%
tl build 4746 - 14.6%
tl 4.3.0 - 18.0% 

Which indicates a performance increase. Closing.