www.cendio.com
Bug 5449 - Re-write tlclient OS X printing dialogs
: Re-write tlclient OS X printing dialogs
Status: CLOSED FIXED
: ThinLinc
Client
: trunk
: PC Unknown
: P2 Normal
: 4.4.0
Assigned To:
:
:
:
: 5257
  Show dependency treegraph
 
Reported: 2015-02-26 10:47 by
Modified: 2015-04-13 09:48 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2015-02-26 10:47:57
Currently, the tlclient uses the Carbon API when showing print dialogs etc.
This includes PMSessionPrintDialog. Unfortunately, this function is not
available on 64-bit Mac OS X. Need to find replacement. 

Btw, there's a lot of duplicated code between printPDF and printRaw; this can
be done better.
------- Comment #1 From cendio 2015-02-26 10:55:54 -------
PMSessionPrintDialog disabled for 64 bit build in 30045.
------- Comment #2 From cendio 2015-02-26 12:30:48 -------
http://boredzo.org/blog/archives/2010-01-18/carbon-dated
------- Comment #3 From cendio 2015-02-27 15:35:54 -------
The OS X printing code was very poorly written so I had to do a lot of general
fixes as part of this work. As of r30071 everything should be working though.

Tester needs to check all aspects of printing on OS X.
------- Comment #4 From cendio 2015-03-20 14:55:40 -------
ThinLinc client shows a printing error messagebox about failed print and points
to logfile for more information. This is the logfile:

2015-03-20T14:39:45: New thinlocal printer job, receiving to: /tmp/lpdYoCQ5w
2015-03-20T14:39:45: Finished receiving printer job
2015-03-20T14:39:45: Printing job with title "Demo system profiles | ThinLinc
by Cendio" and type "application/pdf" (1 copies) on queue "thinlocal".
2015-03-20T14:40:29: There was an error performing the print request


Reproduce like:

 1. Connect using ThinLinc client with "show printer dialog" option enabled
 2. Do a print from within the thinlinc session and at the local print dialog
choose
      to save as pdf. Everything is fine after that...
 3. Do  another print from within the session and you will get the error


The issue affect both 10.06 and 10.10 using 4.3.0post. It's not reproducible
using 4.3.0 client.
Tested against both 4.3.0 and 4.3.0post thinlinc server.

10.10 seems to trigger the error at point 2.
------- Comment #5 From cendio 2015-03-25 10:25:00 -------
Cannot reproduce the issue. However the error dialog sometimes shows up behind
the vncviewer window, so it is most likely just bug 3610.
------- Comment #6 From cendio 2015-03-31 15:04:11 -------
(In reply to comment #5)
> Cannot reproduce the issue. However the error dialog sometimes shows up behind
> the vncviewer window, so it is most likely just bug 3610.

Verified that this is the case.

With that said, testing has shown that this works as expected. Closing.
------- Comment #7 From cendio 2015-04-01 13:19:08 -------
Needs to be retested after gcc fix.
------- Comment #8 From cendio 2015-04-13 09:48:40 -------
(In reply to comment #7)
> Needs to be retested after gcc fix.

Retested using build 4723, works as expected.