www.cendio.com
Bug 5462 - Window/screen update issue using new (HTML5) web client in 4.3
: Window/screen update issue using new (HTML5) web client in 4.3
Status: CLOSED DUPLICATE of bug 4194
: ThinLinc
Web Access
: 4.3.0
: PC Linux
: P2 Normal
: 4.4.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2015-03-06 13:16 by
Modified: 2015-03-06 13:57 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2015-03-06 13:16:54
We're using the HTML5 client to servers running on Scientific Linux 6.6
(approximately a clone of RHEL 6.6). Thinlinc packages have versions like 
4.3.0-4538.

Some of our users see "hangs" when working with the system doing various tasks.
These includes viewing images (using eog) with different names, switching
workspaces within the GNOME Desktop or similar every day tasks.

Typically, these hangs normally resolve themselves after a while without
administrative interaction but the time it takes may vary greatly.

If we understand our users correctly, it doesn't always help closing the
connection and logging on again.

It seems certain users/clients can trigger this issue rather often whereas we
haven't been able to trigger it at all with some clients.

We don't see any clear explanation looking at the web browsers used, reportedly
the issue has occurred with at least the latest released version of Firefox as
well as Chrome unstable.

For clarity and completeness: to have the servers isolated from the world,
actual websocket connections are proxied via a nginx server. However
interaction is still possible (as demonstrated in the terminal window in the
movie attached to this bug) we believe this is not likely an issue with the
data stream but rather a redraw bug or client/server mismatch somehow but we
felt it worth mentioning.
------- Comment #1 From 2015-03-06 13:20:36 -------
Movie turned out to be large to upload. Hosted at
<https://drive.google.com/file/d/0B3lo49vQbUstVnBmSk8tdkZKSjA/view?usp=sharing>
for the time being.
------- Comment #2 From cendio 2015-03-06 13:56:58 -------
Hi Pontus and thank you for the report.

This is a known issue and it occurs due to badly written applications that
expect an audio server and hangs if such a server isn't available. The HTML5
client does not support audio, see bug 4822. You will probably see the same
issue on our native clients if you disable audio in the client settings.

There are two things which you can try which could solve your issue:

* In Gnome 2 settings on the server, disable this setting:
   Sound Preferences -> Sounds -> "Play alerts and sound effects"

* Disable ThinLinc audio completely from the server side by creating the file
  /opt/thinlinc/etc/xstartup.d/60-disable-pa.sh with the following content:

    unset PULSE_SERVER
    unset PULSE_COOKIE

  Only newly created sessions will be affected after this change.


A proper longterm solution from our side will be to solve bug 4194.

*** This bug has been marked as a duplicate of bug 4194 ***