Bug 5495 - cannot close/disconnect client when constantly being fed data
Summary: cannot close/disconnect client when constantly being fed data
Status: CLOSED FIXED
Alias: None
Product: ThinLinc
Classification: Unclassified
Component: VNC (show other bugs)
Version: trunk
Hardware: PC Unknown
: P2 Normal
Target Milestone: 4.8.0
Assignee: Peter Åstrand
URL:
Keywords: relnotes, samuel_tester
: 6118 (view as bug list)
Depends on: 6153
Blocks:
  Show dependency treegraph
 
Reported: 2015-04-17 14:45 CEST by Pierre Ossman
Modified: 2017-03-24 16:28 CET (History)
1 user (show)

See Also:
Acceptance Criteria:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pierre Ossman cendio 2015-04-17 14:45:39 CEST
The socket handler will keep looping until it has managed to drain all data from the socket. If this never happens then we never return to the main loop and check if we should exit.

I've tested this on OS X just by having glxgears running. It is impossible to close the client until glxgears is terminated.

This is not a regression and has probably been present since we ported things to FLTK.
Comment 1 Pierre Ossman cendio 2017-01-05 13:20:35 CET
*** Bug 6118 has been marked as a duplicate of this bug. ***
Comment 5 Samuel Mannehed cendio 2017-02-10 15:05:51 CET
Verified that the problem exists with tlclient 4.7.0 on OS X 10.8. Verified that it is fixed in build 5369. Works well.