www.cendio.com
Bug 5504 - Register ThinLinc client config mime type on Mac OS X
: Register ThinLinc client config mime type on Mac OS X
Status: CLOSED FIXED
: ThinLinc
Client
: 4.3.0
: PC Unknown
: P2 Normal
: 4.6.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2015-04-23 08:13 by
Modified: 2016-04-12 12:46 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2015-04-23 08:13:40
What I understand this is done with CFBundleDocumentTypes property in the
Info.plist.

I made a quick test and got the ThinLinc client started when clicking a
.tlclient file. Should be fairly simple to fix this issue.
------- Comment #3 From cendio 2016-01-26 13:53:25 -------
Fixed. The tester should verify:

* Documentation. 

* Use client config by double click on a .tlclient file. 

* Run the client via tlclient.cgi

* Drag a .tlclient file to tlclient icon in Dock. Should work both before and
after login to TL server. 

A bonus test would also be to launch a client config via Applescript.
------- Comment #4 From cendio 2016-01-26 13:54:44 -------
*** Bug 3656 has been marked as a duplicate of this bug. ***
------- Comment #5 From cendio 2016-01-26 13:55:21 -------
(In reply to comment #4)
> *** Bug 3656 has been marked as a duplicate of this bug. ***

Due to this change, make sure to test on multiple OS X versions.
------- Comment #8 From cendio 2016-02-05 13:42:10 -------
When a ThinLinc Client is open and (partially) hidden behind other
applications, opening a ThinLinc Client configuration file will first focus and
raise the existing ThinLinc Client above other windows and then start a new
client instance with the desired configuration.

If the ThinLinc Client is on another desktop, OS X will move to that desktop
and start the new client there instead of on the desktop you're currently at.
------- Comment #10 From cendio 2016-02-08 14:37:17 -------
(In reply to comment #8)
> When a ThinLinc Client is open and (partially) hidden behind other
> applications, opening a ThinLinc Client configuration file will first focus and
> raise the existing ThinLinc Client above other windows and then start a new
> client instance with the desired configuration.
> 
> If the ThinLinc Client is on another desktop, OS X will move to that desktop
> and start the new client there instead of on the desktop you're currently at.

Moved to Bug 5792.
------- Comment #11 From cendio 2016-02-08 18:29:05 -------
(In reply to comment #10)
> (In reply to comment #8)
> > When a ThinLinc Client is open and (partially) hidden behind other
> > applications, opening a ThinLinc Client configuration file will first focus and
> > raise the existing ThinLinc Client above other windows and then start a new
> > client instance with the desired configuration.
> > 
> > If the ThinLinc Client is on another desktop, OS X will move to that desktop
> > and start the new client there instead of on the desktop you're currently at.
> 
> Moved to Bug 5792.

Fine.

> * Use client config by double click on a .tlclient file. 

Works fine. The "open" command also works fine.

> * Run the client via tlclient.cgi

Works with Firefox. Chrome saves the config file to disk by default, Safari
hits bug 5707 and won't progress to the step where it downloads a configuration
file.

> * Drag a .tlclient file to tlclient icon in Dock. Should work both before and after login to TL server. 

Works both before and after login.