www.cendio.com
Bug 5515 - panning blurs screen on Android
: panning blurs screen on Android
Status: CLOSED FIXED
: ThinLinc
Web Access
: pre-1.0
: PC Unknown
: P2 Normal
: 4.5.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2015-04-30 13:22 by
Modified: 2015-09-25 13:56 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2015-04-30 13:22:46
Chrome applies some sort of blur to the data when you copy it around on the
canvas as part of the panning operation. Not sure at this point if it is an
update of noVNC or Chrome that causes it. ThinLinc 4.3.0 had broken panning so
we cannot test that for comparison.
------- Comment #1 From cendio 2015-08-14 17:11:18 -------
This happens when using panning in Firefox 40 on our Nexus 7 tablet as well.
However it does not happen in Firefox 40 on my Samsung phone.

I submitted a bug in Firefox:

https://bugzilla.mozilla.org/show_bug.cgi?id=1194719

The simple testcase attached to that bug does not trigger an error on Chrome.

It seems to be fixed in Firefox 41 since I can't reproduce it on both the
tablet nor on my phone. The problem still existed in Chrome on Android however.

To work around the issue we have disabled image-smoothing and stopped using
float-coordinates.

This was done in commit 30666.
------- Comment #2 From cendio 2015-08-17 12:47:35 -------
To clarify:

* We saw the bug in recent versions of both Chrome and Firefox on Android.
* The bug seemed to be a combination of bad code from our part and a browser
bug.
* Can reliably reproduce browser bug in Firefox 40 but not in Chrome.
* Can't reproduce the browser bug in Firefox 41 beta on Android.
* Our bad code was fixed and a workaround for the browser bugs was committed in
r30666.
------- Comment #3 From cendio 2015-08-17 13:22:15 -------
Works well on both firefox and chrome now.