www.cendio.com
Bug 5516 - Allow both mouse and touch events simultaneously in the HTML5 client
: Allow both mouse and touch events simultaneously in the HTML5 client
Status: CLOSED DUPLICATE of bug 5983
: ThinLinc
Web Access
: trunk
: PC Unknown
: P2 Normal
: 4.8.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2015-04-30 13:41 by
Modified: 2017-02-14 10:18 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2015-04-30 13:41:33
Currently we only accept either mouse or touch. There are screens intended for
desktop computers which allow for touch and many laptops do have touch screens.

A mouse connected to an android tablet seems to work fine however. The problem
is centered around more traditional desktop platforms and when you have a touch
screen on such.
------- Comment #1 From cendio 2015-04-30 13:46:59 -------
Concerns regarding detection of touch devices are related to this bug:
http://www.stucox.com/blog/you-cant-detect-a-touchscreen/#touch-apis

As seen in bug 5506 for example, we got a false positive for touch detection
which results in problems for the mouse.

And here is the upstream issue for noVNC:
https://github.com/kanaka/noVNC/pull/369
------- Comment #2 From cendio 2017-02-13 16:25:39 -------
Isn't this fixed by now?
------- Comment #3 From cendio 2017-02-13 16:46:36 -------
(In reply to comment #2)
> Isn't this fixed by now?

Duplicate of bug 5983?
------- Comment #4 From cendio 2017-02-14 10:18:09 -------

*** This bug has been marked as a duplicate of bug 5983 ***