www.cendio.com
Bug 5597 - drop support for Windows 2003
: drop support for Windows 2003
Status: CLOSED FIXED
: ThinLinc
Other
: pre-1.0
: PC Unknown
: P2 Normal
: 4.8.0
Assigned To:
:
:
:
: 5879
  Show dependency treegraph
 
Reported: 2015-07-15 10:23 by
Modified: 2017-03-20 17:09 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2015-07-15 10:23:41
Windows 2003 has now finally lost even extended support from Microsoft. So it's
time to start considering dropping support for that system from our end as
well. Besides reduced need for testing, there are also some components that are
Windows 2003 specific, like tlsnd and tlgina, that we can now get rid of.
------- Comment #1 From cendio 2016-04-28 08:48:38 -------
*** Bug 5863 has been marked as a duplicate of this bug. ***
------- Comment #2 From cendio 2016-05-09 15:40:18 -------
The components mentioned in comment #0, tlsnd and tlgina which are parts of
WTS-tools doesn't seem to have much use anymore. If we overview WTS-tools:

* tl-loadagent - probably only useful for 2003?
* tl-is-appsession - very specific use-cases
* tlsnd - only when u want mic, only for 2003
* tlgina - only for 2003

Aaand tlsnd doesn't even work, see bug 5872.

We should consider removing WTS-tools when doing this bug.
------- Comment #3 From cendio 2016-05-10 10:37:35 -------
We also have seamlessrdp in wts-tools, which is currently relevant for all
Windows server versions.
------- Comment #4 From cendio 2016-12-02 11:03:11 -------
(In reply to comment #2)
> * tlsnd - only when u want mic, only for 2003

rdesktop includes special code for mic support using tlsnd , this should also
be removed.
------- Comment #6 From cendio 2016-12-05 09:36:50 -------
(In reply to comment #4)
> (In reply to comment #2)
> > * tlsnd - only when u want mic, only for 2003
> 
> rdesktop includes special code for mic support using tlsnd , this should also
> be removed.

A vendordrop of rdesktop was done in commit r31924 which removes the
implementation of rdpsn_rec extension in rdesktop.
------- Comment #11 From cendio 2017-03-03 09:24:18 -------
I can not find any more relevant references to Windows 2003. Should be all
done.
------- Comment #12 From cendio 2017-03-06 12:41:52 -------
Looks good. Can't find any more unwelcome traces of windows 2003.