www.cendio.com
Bug 5605 - incorrect canvas position after pan and resize
: incorrect canvas position after pan and resize
Status: CLOSED FIXED
: ThinLinc
Web Access
: pre-1.0
: PC Unknown
: P2 Normal
: 4.8.0
Assigned To:
:
:
: 5611
: 6132
  Show dependency treegraph
 
Reported: 2015-08-11 15:51 by
Modified: 2017-03-27 14:18 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2015-08-11 15:51:31
The canvas is positioned incorrectly in (at least) Firefox 39 on Android after
doing this:


 - Start a session in the normal 1:1 mode
 - Reconfigure the desktop to something larger
 - Pan a bit
 - Rotate the device to trigger a resize

The canvas will now be positioned incorrectly by the same amount as the panning
that was previously performed.

The "dead" areas exposed show old data, rather than some background colour, so
this might be a browser bug. OTOH, we're not behaving very nice by fighting
with the browser over the canvas position so this might be an undefined corner
case.
------- Comment #1 From cendio 2015-11-25 16:10:22 -------
Seeing the same issue on Chrome 46 on Android.
------- Comment #2 From cendio 2017-01-10 16:51:41 -------
Fixed in upstream noVNC by double buffering:
https://github.com/novnc/noVNC/pull/699
------- Comment #4 From cendio 2017-02-03 16:04:47 -------
This is fixed now.
------- Comment #5 From cendio 2017-02-06 15:27:07 -------
Verified that i could reproduce the issue against our internal 4.7.0 server
using Firefox 50.1.0 and Chrome 56.0.2924.87 on android.

Did the same tests against 4.7.0post 5365 and the problem is not reproducible.

Works as expected.