www.cendio.com
Bug 5610 - Sometimes we don't get a framebuffer update after panning
: Sometimes we don't get a framebuffer update after panning
Status: CLOSED FIXED
: ThinLinc
Web Access
: trunk
: PC Unknown
: P2 Normal
: 4.8.0
Assigned To:
:
:
: 5611
: 6132
  Show dependency treegraph
 
Reported: 2015-08-20 11:07 by
Modified: 2017-03-27 14:19 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2015-08-20 11:07:22
When panning we require new data from the server to draw the new parts of the
screen. This seems to be working very inconsistently. The result is that you
have blank parts of the screen until you do something else which will trigger
the update.

It is a lot easier to reproduce on touch devices, where you don't have a mouse
cursor.
------- Comment #1 From cendio 2015-08-20 11:43:17 -------
Upstream bug: https://github.com/kanaka/noVNC/issues/517
------- Comment #2 From cendio 2017-01-10 16:52:42 -------
Fixed in upstream by double buffering: https://github.com/novnc/noVNC/pull/699

We would no longer need frame buffer updates after panning.
------- Comment #4 From cendio 2017-02-03 16:02:40 -------
Fixed now.
------- Comment #5 From cendio 2017-02-06 14:58:08 -------
Works as expected