www.cendio.com
Bug 5672 - tlclient takes some time to exit on Linux and OS X
: tlclient takes some time to exit on Linux and OS X
Status: CLOSED FIXED
: ThinLinc
Client
: pre-1.0
: PC Unknown
: P2 Normal
: 4.6.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2015-10-12 11:13 by
Modified: 2016-04-12 12:47 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2015-10-12 11:13:01
Similar to bug 1778, but this time for the non-Windows platforms.

The problem is that we fail to detect vncviewer terminating in a timely manner
as we poll for it exiting. We also seem to go an extra round in the main loop
for unknown reasons. A quick strace shows us taking almost 2 seconds to
terminate after SIGCHLD.
------- Comment #3 From cendio 2015-11-20 14:05:46 -------
Verified using client build 4949 on both Linux and OS X.

Works great.