www.cendio.com
Bug 5681 - Support for eLux RP5
: Support for eLux RP5
Status: CLOSED FIXED
: ThinLinc
Client platforms
: trunk
: PC Unknown
: P2 Normal
: 4.6.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2015-10-27 09:53 by
Modified: 2016-12-05 14:56 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2015-10-27 09:53:40
eLux RP5 has a new package format. Packages are called UC_RP5-1.0 instead of
UC_RP-1.0. A rename is not enough to load them into Elias.
------- Comment #1 From cendio 2015-10-27 11:21:43 -------
We need to investigate how easy this is to upgrade, which terminals are
supported, does it cost anything, are devices shipping with this version, etc?
------- Comment #3 From cendio 2016-02-08 10:05:46 -------
Unicon have been contacted on issue 18535 to get new licences.
------- Comment #4 From cendio 2016-02-08 10:33:40 -------
The following eLux terminals are no longer supported on RP 5:

Futro S100
Futro S450 (v2 still supported)
Futro S550 (v2 still supported)
Esprimo C700   
Esprimo C710   
Esprimo E700   
Esprimo E710   

NEXceed-IV     
NEXtreme-I


eLux can also be used on terminals that originally run something different, and
that list has also lost a few entries:

t5545  
t5565  
t5570  
st5548         

UD3 Nano       
UD5 Nano      

Itona F-Series F24 (BIOS V9F8-EL)      
Itona MD-Series (BIOS MdE1-EL)
------- Comment #5 From cendio 2016-02-08 10:36:46 -------
There doesn't seem to be any extra cost involved for upgrading AFAICT, and
Unicon's web page states:

> Subscription ensures that you can always use the latest software versions of
> eLux and Scout Enterprise as well as the latest application versions.

http://www.unicon-software.com/en/products/subscription/
------- Comment #6 From cendio 2016-02-08 10:46:21 -------
The machines we have are a Nexceed and a S900. So one of them is possible to
upgrade. Or we could buy a new terminal.

For reference, eLux RL is supported until 2016-03-31 (i.e. it will be
unsupported by the time the next ThinLinc is out). eLux RP 4 is supported until
2018-03-31 though.
------- Comment #7 From cendio 2016-02-18 10:16:29 -------
I have formatted our S900 and installed a fresh RP 4.11 on it. It is connected
to Scout and working properly. The plan is that we upgrade this machine to RP
5.

I have also disconnected and put aside our Nexceed terminal. This machine will
continue having RP 4, so that we can test it in the future if needed.
------- Comment #8 From cendio 2016-02-18 16:20:41 -------
I tried out the mass upgrade method to update our S900 from RP4 to RP5. AFAICT
it worked out fine. The graphics freaked out during the upgrade, but a few
minutes later it was rebooted with an updated firmware.

I also did an updated ThinLinc package as part of this. Simply changing the
container name was sufficient to get it to install. Will still need to do
proper testing that everything works.
------- Comment #9 From cendio 2016-02-18 17:13:08 -------
The client seems to work just fine on the new eLux. I've tested:

 - Multihead
 - Smart card auth
 - Smart card redir
 - Local drives
 - Sound
 - Local printer
------- Comment #11 From cendio 2016-03-10 15:32:52 -------
Test results:

 ✓ Basic functionality
 ✓ Authentication methods
   ✓ Password
   ✓ Public key
   ✓ Smart card
   ✗ Kerberos (bug 5816)
 ✓ Local devices
   ✓ Sound
   ✓ Serial ports
   ✓ Drives
   ✓ Printing
   ✓ Smart card readers
 ✓ Multi monitor handling