www.cendio.com
Bug 5768 - Build a client package for Wyse Suse Linux 11 SP 3
: Build a client package for Wyse Suse Linux 11 SP 3
Status: CLOSED FIXED
: ThinLinc
Client platforms
: 4.4.0
: PC Unknown
: P2 Normal
: 4.6.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2016-01-12 10:47 by
Modified: 2017-11-30 16:06 (History)


Attachments
Wyse Device name Translation Guide (46.85 KB, application/pdf)
2016-02-22 09:14, Peter Åstrand
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2016-01-12 10:47:37

    
------- Comment #1 From cendio 2016-01-14 11:12:53 -------
One idea is that we should solve this bug by removing support for SP2 and
adding support for SP3 instead. However, we need to check if "all" terminals
running SP2 can be upgraded to SP3.
------- Comment #2 From cendio 2016-01-19 13:46:08 -------
The latest release notes [1] of wyse upgrade is for two versions SP2 Version
11.2.092 and SP3 Version 11.3.092. It seems that only 3 out of 10 clients
supports SP3. In another words, for now only three thin clients supports SP3
and the others can't be upgrade to SP3.

https://appservices.wyse.com/supportdownload/5series/SLETC%2011_%20SP2_%20SP3_%20MR6_ReleaseNotes.pdf
------- Comment #3 From cendio 2016-01-26 10:42:48 -------
We have decided to drop support for SP2 and add support for SP3 instead,
despite that not all terminals can be upgraded. We will add a note to platform
specific notes though, describing which versions of ThinLinc works with SP2.
------- Comment #5 From cendio 2016-02-22 09:14:01 -------
Created an attachment (id=673) [details]
Wyse Device name Translation Guide
------- Comment #6 From cendio 2016-02-22 09:18:35 -------
(In reply to comment #5)
> Created an attachment (id=673) [details] [details]
> Wyse Device name Translation Guide

If I understand this correctly, SP3 is only for Quad terminals, which currently
means:

D50Q = "Wyse 5020 thin client with Linux"
Z50Q = "Wyse 7020 thin client with Linux"
Z50QQ = "Wyse 7020 thin client, quad display, with Linux"
------- Comment #7 From cendio 2016-02-22 09:28:00 -------
(In reply to comment #6)
> (In reply to comment #5)
> > Created an attachment (id=673) [details] [details] [details]
> > Wyse Device name Translation Guide
> 
> If I understand this correctly, SP3 is only for Quad terminals, which currently
> means:
> 
> D50Q = "Wyse 5020 thin client with Linux"
> Z50Q = "Wyse 7020 thin client with Linux"
> Z50QQ = "Wyse 7020 thin client, quad display, with Linux"

http://ea-data.com/ does not have these terminals. http://www.dell.com gives me
"Error Encountered" when clicking
http://www.dell.com/se/foretag/p/desktops-n-workstations.aspx .
------- Comment #8 From cendio 2016-02-22 12:35:06 -------
http://www.technicalhelp.de/2016/01/22/suse-linux-mr7-finalized/ says:

"Today Dell has uploaded the brand new SUSE Linux MR7 (Maintenance Release) to
their website. MR7 includes an AES password encryption tool
Unified image: SP3 support for dual and quad core thin clients"

If this is for Wyse, this means it might be possible to upgrade other terminals
to SP2 after all.
------- Comment #9 From cendio 2016-02-22 12:53:55 -------
(In reply to comment #8)
> http://www.technicalhelp.de/2016/01/22/suse-linux-mr7-finalized/ says:
> 
> "Today Dell has uploaded the brand new SUSE Linux MR7 (Maintenance Release) to
> their website. MR7 includes an AES password encryption tool
> Unified image: SP3 support for dual and quad core thin clients"
> 
> If this is for Wyse, this means it might be possible to upgrade other terminals
> to SP2 after all.

This was true.
https://appservices.wyse.com/pages/serviceandsupport/support/dlOraFW.asp?which=179&model=Z50Q/D50Q/Z50QQ%28Wyse%20Linux%29
has a MR7 release notes which says:

"""
Unified Imaging
This feature allows D50D, Z50D thin clients to have SLED 11 SP3 image on them.
The major idea
of Unified Imaging is to make all the dual core/quad core thin clients which
are currently running
on SLED 11 SP2 image to run on SLED 11 SP3 image. From this release, we will
have only SP3
which supports all the dual core and quad core thin clients. This feature
allows the users to have
only one image, instead of two. From the Engineering point of view it will be
beneficial for
development as this reduces our development and test cycles going further.
"""

The text also says:

NOTE: We are not supporting X50M and Z50D (TPM Hardware - NIST BIOS) as part of
this release.

Also, it seems they forgot (or pretends to forgot...) about Z50S. 

X50M is still sold: http://www.dell.com/se/foretag/p/wyse-x-class/pd

Z50D seems to be somewhat special; NIST BIOS. 

Cannot find any information about Z50S - it is probably retired. 

To summarize, if we drop support for SP2, I believe this will only be
problematic for X50M users, but those can probably run TL 4.5.0. This means
that the alternative of supporting SP3 *instead* of SP2 looks good.
------- Comment #11 From cendio 2016-03-04 14:29:53 -------
I've upgraded one of our Z50D to SP3 (11.3.106) and did some testing:

 - Smart card auth and redir
 - Sound
 - Local printer
 - Local drives (but bug 5815)

However, there are regressions:

 - The displayport refuses to work (the monitor goes nuts), so multi-head is
gone
 - Graphics performance has taken a nose dive

I'm doing a full factory reset to see if that sorts it out.
------- Comment #13 From cendio 2016-03-04 16:11:41 -------
A build system bug meant that I was accidentally running a much older version
of the client. But unfortunately the performance problem remains after doing a
factory reset and upgrading the client properly.
------- Comment #14 From cendio 2016-03-07 15:50:31 -------
I've also tested the D50D now and it shows the same issues. However I did make
some new discoveries:

a) The DisplayPort issue is monitor specific. It works with my newer Dell
monitors.

b) The performance issue sometimes disappears when you switch resolution.
------- Comment #16 From cendio 2016-03-10 14:37:43 -------
Re-tested using a nighly build. Works fine AFAICT.
------- Comment #17 From cendio 2016-03-17 08:59:15 -------
Verified commits and that client-bundle contains a package for SP3. Waiting for
hw client and hopefully an update of SP3 (graphics part) for further testing of
the client.
------- Comment #18 From cendio 2016-03-31 14:25:10 -------
I got an updated driver from Dell and the issues are gone AFAICT. So it should
be fine to proceed with testing.
------- Comment #19 From cendio 2016-04-20 13:41:50 -------
Wyse Suse Linux 11 SP3 isn't installed with any Kerberos utilities for testing
a Kerberos login, and doesn't seem to create any device nodes for our USB to
serial adapter.

 - Authentication methods
   ✓ Password
   ✓ Public key
   ✓ Smart card
   ✗ Kerberos
 - Local devices
   ✓ Sound
   ✗ Serial ports
   ✓ Drives
   ✓ Printing
   ✓ Smart card readers
 ✓ Multi monitor handling
 ✓ Check for stray temporary files