www.cendio.com
Bug 5983 - Web Access problems on devices with both touch screen and mouse
: Web Access problems on devices with both touch screen and mouse
Status: CLOSED FIXED
: ThinLinc
Web Access
: 4.6.0
: PC Unknown
: P2 Normal
: 4.8.0
Assigned To:
:
:
:
: 6132
  Show dependency treegraph
 
Reported: 2016-09-09 14:49 by
Modified: 2017-04-20 11:00 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2016-09-09 14:49:28
We got a report from a customer that when testing a new Chromebook model
(Lenovo ThinkPad Yoga 11E) with touch screen, they could not use the built-in
touch pad with the HTML5 client. They could interact just fine with the web
browser and the rest of the system. On a Chromebook without touch screen (HP
Chromebook 11 G4), the touch pad worked just fine with the HTML5 client.
------- Comment #3 From cendio 2016-09-26 15:48:28 -------
We now have a Chromebook (Lenovo ThinkPad Yoga 11e). Can reproduce the issue.
------- Comment #4 From cendio 2016-10-24 15:14:03 -------
Fixed in upstream now.
------- Comment #5 From cendio 2016-10-26 15:51:52 -------
The same issue exists for Microsoft Surface devices. It is a general issue that
our HTML5 client for now only handles EITHER touch OR mouse, never both. This
is fixed upstream.

Also note that the control bar handle can't be moved using touch in IE and Edge
on Microsoft Surface devices. This is also fixed upstream now.
------- Comment #6 From cendio 2016-10-27 10:25:36 -------
So, to summarize; On devices such as Chromebooks and Microsoft Surfaces, which
have both a mouse and a touch screen, there are a number of issues with mouse
input in the HTML5 client.

Issues found on a Microsoft Surface device using Windows 10:

* Touch input doesn't work in IE or Edge
* Mouse input doesn't work in Chrome
* The new control bar handle can't be moved using touch on IE and Edge

(Note that both mouse and touch works in Firefox.)


Issue found on a Chromebook with a touch screen:

* Mouse input doesn't work
------- Comment #9 From cendio 2017-02-03 16:23:08 -------
Fixed now.
------- Comment #10 From cendio 2017-02-06 15:33:54 -------
While touch + normal pointer events seems to work just fine now, there is a
problem with touch input.

I've seen this on the Yoga 11e Chromebook, in "tablet" mode (keyboard folded
away).

Steps to reproduce:
 1. Start a session

 2. Bring out keyboard to decrease screen size without resizing session

 3. Grab the control bar and drag it up to reach the bottom half of the session

 4. Click and drag the desktop to see touch events happen *not* beneath your
fingers, but offset by approximately the amount you scrolled.
------- Comment #11 From cendio 2017-02-06 16:14:04 -------
(In reply to comment #10)
> While touch + normal pointer events seems to work just fine now, there is a
> problem with touch input.
> 
> I've seen this on the Yoga 11e Chromebook, in "tablet" mode (keyboard folded
> away).
> 
> Steps to reproduce:
>  1. Start a session
> 
>  2. Bring out keyboard to decrease screen size without resizing session
> 
>  3. Grab the control bar and drag it up to reach the bottom half of the session
> 
>  4. Click and drag the desktop to see touch events happen *not* beneath your
> fingers, but offset by approximately the amount you scrolled.

Not a regression can reproduce with ThinLinc 4.7.0. Can also reproduce on our
Windows 10 tablet. Created bug 6163.
------- Comment #12 From cendio 2017-02-06 17:08:23 -------
(In reply to comment #11)
> Not a regression can reproduce with ThinLinc 4.7.0. Can also reproduce on our
> Windows 10 tablet. Created bug 6163.

In that case, closing. Both touch and mouse works at the same time on the
Chromebook.
------- Comment #13 From cendio 2017-02-14 10:18:09 -------
*** Bug 5516 has been marked as a duplicate of this bug. ***