www.cendio.com
Bug 6053 - panning mode is incorrectly active on Internet Explorer
: panning mode is incorrectly active on Internet Explorer
Status: CLOSED FIXED
: ThinLinc
Web Access
: trunk
: PC Unknown
: P2 Normal
: 4.8.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2016-10-13 11:15 by
Modified: 2017-04-21 14:07 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2016-10-13 11:15:25
The HTML client forces panning mode for Internet Explorer when the session is
larger than the browser window. All other browsers get scroll bars.
------- Comment #1 From cendio 2016-10-19 15:52:37 -------
This bug was introduced as part of a vendordrop (r30543) that was done on bug
5454. The actual error is a typo which is now fixed upstream:

https://github.com/kanaka/noVNC/commit/8473635a09905986981aa5d31b716af0c7973925

This means that this bug should be resolved when we do the next vendordrop of
noVNC.
------- Comment #2 From cendio 2017-04-10 16:37:37 -------
(In reply to comment #1)
> This bug was introduced as part of a vendordrop (r30543) that was done on bug
> 5454. The actual error is a typo which is now fixed upstream:
> 
> https://github.com/kanaka/noVNC/commit/8473635a09905986981aa5d31b716af0c7973925
> 
> This means that this bug should be resolved when we do the next vendordrop of
> noVNC.

This doesn't seem to be true due to that I just tested IE on Windows 10
platform and does not still get any scrollbars.
------- Comment #3 From cendio 2017-04-11 10:20:59 -------
It looks like panning mode is in fact disabled as expected now after the
vendordrops. However, just as Henrik says, we still don't get scrollbars.

Reassigning from 'LowPrio' to '---' for discussion. One possible workaround
could be to force panning mode for IE (lol).
------- Comment #4 From cendio 2017-04-11 10:36:33 -------
Furthermore, this could be viewed as a regression since in 4.7.0 we can pan
using the 'hand'.
------- Comment #6 From cendio 2017-04-11 16:21:36 -------
Properly fixed now.

Tester needs to verify that both client-initiated and server-initiated (xrandr)
resize still works in all five browsers, and both on a touch device and a
non-touch device:

 * Firefox
 * Chrome
 * Safari
 * Edge
 * IE
------- Comment #7 From cendio 2017-04-11 16:27:49 -------
It's also important for the tester to verify that scrollbars / panning hand are
enabled correctly when testing the resize.
------- Comment #8 From cendio 2017-04-12 10:47:44 -------
Verified that i got scrollbars in Chrome, Firefox, IE and Edge when tested on
Windows 10 desktop. Also tested using Safari on OS X.

Works as expected.
------- Comment #10 From cendio 2017-04-19 13:40:26 -------
Tested Chrome, Firefox, Edge and IE 11 on Windows Touch for which panning with
the hand on the control bar works.

With Edge closing the keyboard causes a resize, so panning can only be tested
while keyboard is up. Because pasting with middle mouse button does not work
(bug #6345).
------- Comment #11 From cendio 2017-04-19 16:09:22 -------
Verified that panning works on all browsers on iOS and Windows Touch.