www.cendio.com
Bug 6072 - session resize doesn't work with Windows 2012 R2
: session resize doesn't work with Windows 2012 R2
Status: CLOSED DUPLICATE of bug 5290
: ThinLinc
| rdesktop (deprecated)
: 1.3.1
: PC Unknown
: P2 Normal
: 4.7.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2016-10-19 13:12 by
Modified: 2016-12-05 15:13 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2016-10-19 13:12:16
Resizing the session almost works. The session dimensions are changed, as are
the rdesktop window dimension. However the graphics are only updated in the
area of the original size. The rest remain black.

Tested with 4.7.0rc2 and 4.6.0 on SLES 12.

Works fine with Windows 2003 R2.
------- Comment #1 From cendio 2016-10-25 11:04:41 -------
We need more information here. We should test on more distributions, older
ThinLinc versions and more Windows versions.
------- Comment #2 From cendio 2016-10-26 14:41:31 -------
Works fine with nightly build 5273 against marina.thinlinc.com (2008 R2
standard), running on CentOS 6.
------- Comment #3 From cendio 2016-10-26 15:22:17 -------
(In reply to comment #2)
> Works fine with nightly build 5273 against marina.thinlinc.com (2008 R2
> standard), running on CentOS 6.

Using same TL server, connecting to Windows 2012R2 server in admin mode: Still
works fine.
------- Comment #4 From cendio 2016-10-26 15:33:01 -------
Note that MS introduced support for changing session size without reconnect in
Windows 2012 R2:

https://blogs.technet.microsoft.com/enterprisemobility/2013/12/16/resolution-and-scaling-level-updates-in-rdp-8-1/
------- Comment #5 From cendio 2016-10-26 15:53:53 -------
This seems to be related to Windows Updates. When WU said that I had 226
pending updates, it worked correctly. After installing a few of them (196
remaining), the problem happens.
------- Comment #6 From cendio 2016-10-26 16:34:37 -------
It seems the problem starts for me after installing
https://support.microsoft.com/en-us/kb/2934520, which is strange.
------- Comment #7 From cendio 2016-10-28 13:08:24 -------
(In reply to comment #6)
> It seems the problem starts for me after installing
> https://support.microsoft.com/en-us/kb/2934520, which is strange.

Uninstalling this update does not seem to fix the problem.
------- Comment #8 From cendio 2016-10-28 13:24:01 -------
(In reply to comment #5)
> This seems to be related to Windows Updates. When WU said that I had 226
> pending updates, it worked correctly. After installing a few of them (196
> remaining), the problem happens.

Reverting the Windows 2012 r2 snapshot back to when it was created in 2013
still shows this problem.
------- Comment #9 From cendio 2016-10-31 10:03:07 -------

*** This bug has been marked as a duplicate of bug 5290 ***