www.cendio.com
Bug 6175 - images have needlessly high depth
: images have needlessly high depth
Status: CLOSED FIXED
: ThinLinc
Other
: trunk
: PC Unknown
: P2 Normal
: 4.8.0
Assigned To:
:
:
:
: 6132
  Show dependency treegraph
 
Reported: 2017-02-23 17:01 by
Modified: 2017-03-20 16:54 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2017-02-23 17:01:49
For some reason most of our images have been created with a depth of 16 bits
per channel:

> tlclient_192.png: PNG image data, 192 x 192, 16-bit/color RGBA, non-interlaced

The reason is probably because they are generated from a SVG and include
gradients. ImageMagick then likely concludes it cannot reduce the depth without
losing some information.

But this is overkill for us as these images will not be used in places where
such precision is needed. We can save quite a bit of space by reducing things
to the more standard 8 bits per channel. In the case of tlclient_192.png the
difference is 59722 bytes vs 14886 bytes.
------- Comment #3 From cendio 2017-02-23 17:29:13 -------
Tester should check that images still look okay:

 - tlclient icon on Linux
 - webaccess icon
 - tlwebadm icon
 - big logo in tlwebadm
 - logo in tl-xstartup-feedback
 - logo in profile selector
 - logo in rdesktop launcher
------- Comment #6 From cendio 2017-02-28 14:48:31 -------
(In reply to comment #3)

Verified using lxde (OpenBox)

>  - tlclient icon on Linux

Looks good

>  - webaccess icon
>  - tlwebadm icon

Looks good

>  - big logo in tlwebadm

Looks good, except for the clipped antialiasing, however, this is not an
regression.

>  - logo in tl-xstartup-feedback
>  - logo in profile selector
>  - logo in rdesktop launcher

Looks good