www.cendio.com
Bug 6192 - Installer/setup hangs without any window with restricted X server (e.g. Xwayland)
: Installer/setup hangs without any window with restricted X server (e.g. Xwayl...
Status: CLOSED FIXED
: ThinLinc
Server Installer
: trunk
: PC Unknown
: P2 Normal
: 4.10.1
Assigned To:
:
:
:
: 7328 7358
  Show dependency treegraph
 
Reported: 2017-03-14 16:40 by
Modified: 2019-07-09 11:48 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2017-03-14 16:40:44
When running the installer one is asked to enter password for sudo graphically.
After authentication no more graphical dialogs are shown. The tlinstaller
process is still running and a strace shows hang on 'read(0,'.

Both seen on Samuels and Henriks desktops and we are running wayland. No
XAUTHORITY in environment and after running 'xhost +' the problem is solved.
------- Comment #1 From cendio 2017-03-14 16:49:26 -------
This is what the terminal says:

> $ sudo ./install-server
> [sudo] password for samuel: 
> No protocol specified
> /usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py:57: GtkWarning: could not open display
>   warnings.warn(str(e), _gtk.Warning)
> No protocol specified
> Could not start PyGTK. Using text mode fallback...
------- Comment #2 From cendio 2017-03-21 09:44:16 -------
https://bugzilla.redhat.com/show_bug.cgi?id=1274451 ..?
------- Comment #3 From cendio 2017-03-21 10:29:53 -------
Fun. I guess it is time for another rewrite of tl-setup then. :)
------- Comment #4 From cendio 2017-03-21 13:25:34 -------
(In reply to comment #2)
> https://bugzilla.redhat.com/show_bug.cgi?id=1274451 ..?

The short summary is that running graphical applications as root is now
forbidden. The suggested approach is some front-end/back-end solution, ideally
using PolicyKit.
------- Comment #5 From cendio 2017-03-21 13:37:34 -------
We'll do a platform specific note before release with a suggested workaround.

Then we'll move this bug to Next for finding an automatic workaround that
forces text mode.

After that we'll have to have a new discussion on where to go from there and
when.
------- Comment #6 From cendio 2017-03-29 10:59:23 -------
Platform specific note added. Moving to Next.

(Note to self: fix list of bugs in release notes.)
------- Comment #7 From cendio 2017-04-06 14:45:01 -------
Platform Specific Note looks good, workaround works.
------- Comment #8 From cendio 2019-05-15 12:45:00 -------
This also affects RHEL now as they also have Wayland by default.
------- Comment #9 From cendio 2019-06-26 12:00:04 -------
This blog post claims they have backtracked a bit and are working on allowing
root process access to Xwayland at least:

https://blogs.gnome.org/uraeus/2019/06/24/on-the-road-to-fedora-workstation-31/
------- Comment #10 From cendio 2019-07-02 10:20:54 -------
This issue is more general than just Wayland. The issue is that Xwayland is
configured in a very restrictive way, something that is fully possible with any
modern X server. So we should detect and work around that, not do anything
Wayland specific.

This bug is also about getting something working (e.g. text mode) and not
getting full functionality. Bug 7358 has been created to fix this fully.
------- Comment #12 From cendio 2019-07-02 15:14:57 -------
We're now properly falling back to text mode when we cannot find an xauth
cookie. That should hopefully map nicely to the cases we're having problems
with.
------- Comment #13 From cendio 2019-07-09 11:48:12 -------
Works well, release note looks good.

Verified the problem when running "tl-4.10.0-server/install-server" (Note:
without 'sudo') and verified the fix when running
"nightly/server-bundle/install-server". Tested on Fedora 30 with Wayland.
------- Comment #14 From cendio 2019-07-09 11:48:49 -------
We have to remember to remove the Platform Specific Note on release as well.