www.cendio.com
Bug 6980 - graphic glitches on macOS retina/HiDPI screen
: graphic glitches on macOS retina/HiDPI screen
Status: CLOSED WORKSFORME
: ThinLinc
VNC
: trunk
: PC Unknown
: P2 Normal
: 4.9.0
Assigned To:
:
:
: 6079
: 5273
  Show dependency treegraph
 
Reported: 2017-05-22 15:56 by
Modified: 2017-09-21 16:57 (History)
Acceptance Criteria:


Attachments
Example screen shot (1.06 MB, image/png)
2017-05-22 15:56, Pierre Ossman
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2017-05-22 15:56:00
Created an attachment (id=806) [details]
Example screen shot

Bug 6079 added very basic HiDPI support to the client on macOS. Unfortunately
there is a slight graphical glitch in this mode. There seems to be an
off-by-one error when updating the screen, leaving a very thin line of the
previous data. It's easily reproduced by dragging a selection box around on the
desktop (see screenshot).

For now the only workaround is disabling HiDPI for the client. To do this right
click on the app and select "Get Info". In the info dialog there is the option
"Open in Low Resolution". This will get things back to pre-bug 6079 ways.
------- Comment #1 From cendio 2017-09-21 16:57:42 -------
We decided to revert this change in bug 7047, so nothing to do here.