www.cendio.com
Bug 7016 - failure to connect to the agent is listed as failing to connect to VNC
: failure to connect to the agent is listed as failing to connect to VNC
Status: CLOSED FIXED
: ThinLinc
Client
: 1.3.1
: PC Unknown
: P2 Normal
: 4.9.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2017-07-18 09:57 by
Modified: 2017-08-22 10:15 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2017-07-18 09:57:09
This is of course confusing for everyone involved.

The error message in question is:

    "Couldn't set up secure tunnel to VNC!"
------- Comment #2 From cendio 2017-08-11 16:33:32 -------
I can't figure out in which scenario this error message would occur. It's
apparently not related to VNC, but it's not related to a disabled SSH server on
the agent, or the ability to execute thinlinc-login or Xvnc on the server.
------- Comment #3 From cendio 2017-08-22 10:11:32 -------
(In reply to comment #2)
> I can't figure out in which scenario this error message would occur. It's
> apparently not related to VNC, but it's not related to a disabled SSH server on
> the agent, or the ability to execute thinlinc-login or Xvnc on the server.

It's a generic "catch-all" error message when trying to establish the tunnel to
the agent. The earlier error message mentioned "VNC" since the SSH tunnel is
for (among other things) creating a tunnel to the VNC server. A long time ago,
there were no tunnels except for VNC. 

The error message is used for cases such as:

* Local ports already in use
* SSH binary suddenly disappearing
* Unable to create pipes, or fork
* SSH process dying unexpectedly
etc

An easy way or reproduce is:

1) Set agent_hostname=1.2.3.4
2) Connect. The client will "hang".
3) Kill the SSH process
------- Comment #4 From cendio 2017-08-22 10:15:24 -------
Verified build 5541, looks good.