www.cendio.com
Bug 7032 - There is disconnect reason codes that are not handled at all
: There is disconnect reason codes that are not handled at all
Status: CLOSED FIXED
: ThinLinc
| rdesktop (deprecated)
: trunk
: PC Unknown
: P2 Normal
: 4.9.0
Assigned To:
:
:
:
: 6096
  Show dependency treegraph
 
Reported: 2017-09-05 10:29 by
Modified: 2017-12-19 16:33 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2017-09-05 10:29:38
Currently there is a list of 25 disconnect codes handled, but a list found [1],
shows there are at least 10 more to be handled.

[1]
https://social.technet.microsoft.com/wiki/contents/articles/37870.rds-remote-desktop-client-disconnect-codes-and-reasons.aspx
------- Comment #1 From cendio 2017-09-05 10:31:19 -------
We should at least, handle and log as text instead of a number as we do with
the other codes.
------- Comment #2 From cendio 2017-10-02 15:48:59 -------
Official documentation for the codes from the RDP server:

https://msdn.microsoft.com/en-us/library/cc240544.aspx
------- Comment #3 From cendio 2017-10-04 16:45:15 -------
Pull request made upstream:

https://github.com/rdesktop/rdesktop/pull/155
------- Comment #5 From cendio 2017-10-09 16:25:15 -------
Fixed by vendordrop. I have tested using Windows Server 2016. Some other
Windows server versions need to be verified as well.

Testing should verify the following on both 2008 R2 and 2012 R2:
 * Informative and correct log messages for the most common disconnect reasons
 * Code looks good for disconnect reason cases not triggered manually

Also verify the following using any Windows server platform:
 * File names including for example Russian or Swedish characters work as
intended using local drive redirection

(Smart card changes will be tested on bug 7057.)

Seeing as the ThinLinc wrapper scripts have a separate way of displaying some
disconnect reasons (see bug 7033 for example) the testing of this bug involves
looking at the logfile. The messages should appear in xinit.log if rdesktop is
started as a profile.
------- Comment #6 From cendio 2017-10-11 16:43:51 -------
Verified valid messages for codes possible to initiate
(ERRINFO_RPC_INITIATED_LOGOFF, ERRINFO_RPC_INITIATED_DISCONNECT,
ERRINFO_LOGOFF_BYUSER, ERRINFO_RPC_INITIATED_DISCONNECT_BYUSER) on demo system
(2008 R2) and tl01 (2012 R2).

Inspected code change, found no inconsistencies. Looks good.
------- Comment #7 From cendio 2017-12-19 16:33:25 -------
*** Bug 4809 has been marked as a duplicate of this bug. ***