www.cendio.com
Bug 7050 - rdesktop spams lots of rdpsnd_process errors to stderr
: rdesktop spams lots of rdpsnd_process errors to stderr
Status: CLOSED FIXED
: ThinLinc
rdesktop
: 1.3.1
: PC Unknown
: P2 Normal
: 4.9.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2017-09-21 11:08 by
Modified: 2017-10-02 10:37 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2017-09-21 11:08:02
Playing any kind of audio gives a constant stream of these:

> Sound(error): rdpsnd_process(), Opcode = 0x2 Length= 32776
> Sound(error): rdpsnd_process(), Opcode = 0x2 Length= 32776
> Sound(error): rdpsnd_process(), Opcode = 0x6 Length= 4
> Sound(error): rdpsnd_process(), Opcode = 0x2 Length= 32776
> Sound(error): rdpsnd_process(), Opcode = 0x2 Length= 32776
> Sound(error): rdpsnd_process(), Opcode = 0x2 Length= 32776
> Sound(error): rdpsnd_process(), Opcode = 0x2 Length= 32776
> Sound(error): rdpsnd_process(), Opcode = 0x2 Length= 32776

Seen on both Windows 2012 R2 and Windows 2016.
------- Comment #1 From cendio 2017-09-26 13:13:13 -------
Also seen with 2008 R2.
------- Comment #3 From cendio 2017-09-26 16:14:39 -------
It turned out to be simple debug messages that had the wrong log level. Henrik
fixed upstream, brought to ThinLinc with vendordrop.
------- Comment #4 From cendio 2017-09-26 16:21:05 -------
For completeness, this was a regression from the vendordrop on bug 5949 since
the problem was only related to logging.
------- Comment #5 From cendio 2017-10-02 10:37:44 -------
Playing audio no longer produces these log lines.

Tested on Windows 2016 through ThinLinc.