www.cendio.com
Bug 7142 - There is no way to restrict login access to specific hosts / user combinations
: There is no way to restrict login access to specific hosts / user combinations
Status: CLOSED DUPLICATE of bug 6346
: ThinLinc
Web Access
: trunk
: PC Unknown
: P2 Normal
: 4.9.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2018-04-11 12:17 by
Modified: 2018-04-18 13:44 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2018-04-11 12:17:07
When using the native client which uses SSH for authentication one can use it's
mechanism to restrict who can login based on from where using the
'AllowedUsers' in SSHD configuration. This is not possible with ThinLinc Web
Access client.

One possible solution could be using pam.rhosts pam module and /etc/hosts.equiv
configuration for restricting access. However Web Access does not setup the
required 'rhost' and 'ruser' when running pamtester for authentication.
------- Comment #3 From cendio 2018-04-18 13:43:53 -------

*** This bug has been marked as a duplicate of bug 6346 ***