www.cendio.com
Bug 7207 - unclear error message for missing public key file
: unclear error message for missing public key file
Status: CLOSED FIXED
: ThinLinc
Client
: 1.3.1
: PC Unknown
: P2 Normal
: 4.10.1
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2018-06-29 12:43 by
Modified: 2019-04-10 12:40 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2018-06-29 12:43:15
If there is some problem with the public key file specified for authentication
then the client will just state "You are not authorized to connect to this
server." This is probably not the most helpful message when the issue is that
we didn't even try a key.

It is apparent what the problem is in the log though:

> 2018-06-29T12:24:37: ssh[E]: no such identity: foo: No such file or directory
------- Comment #3 From cendio 2018-09-26 16:05:23 -------
See also bug 5317.
------- Comment #6 From cendio 2019-03-05 16:25:26 -------
See also bug 7313.
------- Comment #12 From cendio 2019-04-01 11:18:10 -------
The function works fine on Linux and Windows.

However, the error messages (for this and bug 5317) are perhaps a bit too short
and specific for an end user error message. I think some more details would be
appropriate so that the user can know what to do next.
------- Comment #14 From cendio 2019-04-08 15:12:08 -------
Have improved the messages for the end users now.
------- Comment #16 From cendio 2019-04-10 12:40:18 -------
Looks good now, and also checked release notes.