www.cendio.com
Bug 7225 - OpenGL doesn't work on modern Fedora
: OpenGL doesn't work on modern Fedora
Status: CLOSED FIXED
: ThinLinc
VNC
: trunk
: PC Unknown
: P2 Normal
: 4.10.0
Assigned To:
:
:
: 6177
:
  Show dependency treegraph
 
Reported: 2018-08-15 12:46 by
Modified: 2018-09-28 14:33 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2018-08-15 12:46:20
OpenGL applications have stopped working in ThinLinc recently on Fedora 28:

> [tester@samuel-80 Videos]$ glxgears
> Error: couldn't get an RGB, Double-buffered visual
> [tester@samuel-80 Videos]$ glxinfo
> name of display: :10.0
> Error: couldn't find RGB GLX visual or fbconfig
> 
> [tester@samuel-80 Videos]$ totem tears_of_steel_1080p.webm 
>
> (totem:8748): GLib-CRITICAL **: 12:43:48.133: g_strsplit: assertion 'string != NULL' failed
> Segmenteringsfel (minnesutskrift skapad)

Fedora's own Xvnc seems to work however, it is likely this issue is happening
because we are based on such an old Xorg.
------- Comment #1 From cendio 2018-08-22 17:09:45 -------
Note that this means that desktop environments like GNOME which use OpenGL
can't be used at all in ThinLinc.

When I try to start GNOME I get a black screen followed by a number of crash
popups by abrt (abrt seems like the only thing working in the session) that
says gnome-shell has crashed.
------- Comment #2 From cendio 2018-08-22 17:12:15 -------
Can't see anything relevant in xinit.log for GNOME sessions that can't be
started nor for when glxgears fail in Xfce.
------- Comment #3 From cendio 2018-08-28 16:00:40 -------
Pretty much a duplicate of bug 6177. Fedora managed to screw up the fallback
handling in a recent update which caused the issue:

https://bugzilla.redhat.com/show_bug.cgi?id=1623118

Fortunately that means it is Fedora specific, and should hopefully be fixed
soon.
------- Comment #4 From cendio 2018-09-12 10:00:19 -------
We should no longer need this fallback now since we have upgraded Xorg in bug
5241. I'll verify this along with bug 6177.
------- Comment #5 From cendio 2018-09-14 11:52:01 -------
Can verify that OpenGL now works on Fedora 28 with the nightly build of the
ThinLinc server.