www.cendio.com
Bug 7353 - tl-xinit refuses to work on NFS with Kerberos
: tl-xinit refuses to work on NFS with Kerberos
Status: CLOSED FIXED
: ThinLinc
VSM Agent
: trunk
: PC Unknown
: P2 Normal
: 4.10.1
Assigned To:
:
:
:
: 4955
  Show dependency treegraph
 
Reported: 2019-06-04 14:59 by
Modified: 2019-07-05 15:07 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2019-06-04 14:59:43
This is a light version of bug 4955.

From ThinLinc 4.10.0 (bug 7302) we verify that we can actually switch to the
user's home directory. We added these checks to avoid surprises and weird bugs
later in the session.

However it turns out that some customers were running ThinLinc fine enough even
if the home directory was broken for a while during startup. With this change
they now got a ThinLinc that completely refuses to start sessions.

The proper fix is bug 4955, but until that is fixed we should consider allowing
these "best effort" sessions as they seemed to have worked well enough in
practice. We should probably put a warning in the log though.
------- Comment #2 From cendio 2019-07-02 15:59:10 -------
We don't have a NFS with Kerberos environment here to test with, so I simply
made the home directory inaccessible for a user to test this code path.
------- Comment #3 From cendio 2019-07-05 15:07:03 -------
Tested by removing the -x bit on the user's homedirectory:

> Openbox-Message: Unable to change to home directory "/local/home/tester": √Ötkomst nekas

Works as intended.