Bug 7373 - We're out of sync with upstream TigerVNC
Summary: We're out of sync with upstream TigerVNC
Status: CLOSED FIXED
Alias: None
Product: ThinLinc
Classification: Unclassified
Component: VNC (show other bugs)
Version: trunk
Hardware: PC Unknown
: P2 Normal
Target Milestone: 4.12.0
Assignee: Pierre Ossman
URL:
Keywords: prosaic
Depends on: 5325
Blocks: 7111 7276 3895 3898 5647 5909 7137 7281 7282 7374 7463
  Show dependency treegraph
 
Reported: 2019-09-03 09:23 CEST by Pierre Ossman
Modified: 2020-01-22 13:39 CET (History)
1 user (show)

See Also:
Acceptance Criteria:


Attachments

Description Pierre Ossman cendio 2019-09-03 09:23:27 CEST
Our last vendor drop was 2018-09-21. We need to get back in sync before we can start developing new things for TigerVNC.

6fba8ca7e7c896d3758b8401b35cee0849778fbd seems to be the last commit we got from upstream.
Comment 6 Pierre Ossman cendio 2020-01-17 14:25:12 CET
Seems to work after upgrade. Some detailed testing is needed though:

For X11 libraries:

 * Nothing special. Will be covered by other tests.

For libpng:

 * Check that branding still works in the client

For FLTK (on every OS):

 * Fullscreen (both single and dual monitor)
 * Mouse cursor
 * Keyboard grab
 * Graphics performance (also on bug 7290)
 * Input method handling (that it is disabled when using session)

For TigerVNC:

 * Shadowing
 * Server timeouts (e.g. MaxIdleTimeout)
Comment 7 Alex Tanskanen cendio 2020-01-20 17:28:41 CET
Tested against a RHEL 8 server on clients running Fedora 31, macOS 10.15, Window 10.

libpng:
 ✓ Branding

FLTK:
              Scenario                       | Windows | macOS | linux |
 --------------------------------------------+---------+-------+-------+
 Fullscreen (both single and dual monitor)   |    ✓    |   ✓*  |   ✓   |
 --------------------------------------------+---------+-------+-------+
 Mouse cursor                                |    ✓    |   ✓   |   ✓   |
 --------------------------------------------+---------+-------+-------+
 Keyboard grab                               |    ✓    |   ✓   |   ✓   |
 --------------------------------------------+---------+-------+-------+
 Graphics performance (also on bug 7290)     |    ✓    |   ✓   |   ✓   |
 --------------------------------------------+---------+-------+-------+
 Input method handling (disabled in session) |    ✓    |   ✓   |   ✗** |
 --------------------------------------------+---------+-------+-------+

TigerVNC:
 ✓ Shadowing
 ✓ Server timeouts

* macOS works correctly the first time you launch the client in full screen on both monitors. However, if you disable full screen on both monitors and enable it again it will not work. One screen will be black. Upgrade of FLTK probably broke this since it worked fine on 4.10.1 client.

** This is probably a bug in FLTK. 
   See https://www.fltk.org/str.php?L3502+P0+S-2+C0+I0+E0+V1.3%25+Q
   for more info.
Comment 8 Pierre Ossman cendio 2020-01-21 13:40:09 CET
Input methods issue moved to bug 7465.
Comment 9 Pierre Ossman cendio 2020-01-21 13:43:51 CET
The fullscreen issue seems to have been caused by this commit:

https://github.com/fltk/fltk/commit/39bb0bf488dc1d9051b6eec719df1ac17ca88bc9

Reported upstream here:

https://github.com/fltk/fltk/issues/51
Comment 11 Alex Tanskanen cendio 2020-01-22 13:37:32 CET
(In reply to comment #7)
> 
> * macOS works correctly the first time you launch the client in full screen on
> both monitors. However, if you disable full screen on both monitors and enable
> it again it will not work. One screen will be black. Upgrade of FLTK probably
> broke this since it worked fine on 4.10.1 client.
> 

This issue is now fixed on macOS. Tested with tlclient version 6365 and it works fine. Also tested tlclients on Windows 10 and Fedora 31 and this fix didn't affect these.
Comment 12 Alex Tanskanen cendio 2020-01-22 13:39:30 CET
The issues found when upgrading FLTK (mentioned in comment #7) is now fixed so closing this for now.

Note You need to log in before you can comment on or make changes to this bug.