www.cendio.com
Bug 7383 - Edge always shows default browser cursor
: Edge always shows default browser cursor
Status: CLOSED FIXED
: ThinLinc
Web Access
: trunk
: PC Unknown
: P2 Normal
: 4.11.0
Assigned To:
:
:
: 7365
:
  Show dependency treegraph
 
Reported: 2019-10-08 09:57 by
Modified: 2019-10-23 12:23 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2019-10-08 09:57:08
With the latest edge something goes wrong with the cursor handling and we
always get the default cursor of the local system instead of the cursor used in
the session.

We can see this with versions of ThinLinc that has worked before, so this is
caused by some change in Edge. IE still works fine though.

After some digging we discovered that the detection for data URI support was
broken. Instead of actually detecting what we intended, the code really tested
if the browser supported fallback cursors (i.e. "cursor: a, b, c;"). That
happened to overlap well with support for data URI cursors, but it seems Edge
has now implemented support for fallback but not data URI.

Fixed upstream here:

https://github.com/novnc/noVNC/commit/a1afb2a

So we just need a vendor drop.
------- Comment #1 From cendio 2019-10-22 10:47:04 -------
Verified on nightly build (6272) after vendor drop. 
Tested on Edge 18 and IE 11. Edge now uses fallback cursor as intended alike
IE.
------- Comment #3 From cendio 2019-10-22 13:47:04 -------
The release notes looks good, however, it should say "Microsoft Edge" instead
of just "Edge"