www.cendio.com
Bug 7411 - The context menu hint is displayed even if no hotkey is chosen
: The context menu hint is displayed even if no hotkey is chosen
Status: CLOSED FIXED
: ThinLinc
VNC
: trunk
: PC Unknown
: P2 Normal
: 4.11.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2019-10-25 10:08 by
Modified: 2019-10-28 10:27 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2019-10-25 10:08:07
Steps to reproduce:

1. Start the native ThinLinc client
2. Open the Options and change the "Popup menu key" to 'None'
3. Login to a server
4. Observe that the hint at the top of the screen says:

    "Press  to open the context menu"

We shouldn't display this hint if there isn't a key bound to it.
------- Comment #2 From cendio 2019-10-25 10:49:12 -------
Since this was such a small fix I bypassed the vendordrop routine and committed
directly to ThinLinc. Upstream PR here:

https://github.com/TigerVNC/tigervnc/pull/894

Built and tested on Fedora 30.
------- Comment #3 From cendio 2019-10-28 10:27:19 -------
Looks good. Got a confusing hint in the previous version with "None"
configured, but nothing at all now. Also verified that that a properly
configured menu key still gets the hint.