Bug 7425 - Alt+Space sends nobreakspace in Safari
Summary: Alt+Space sends nobreakspace in Safari
Status: CLOSED WORKSFORME
Alias: None
Product: ThinLinc
Classification: Unclassified
Component: Web Access (show other bugs)
Version: trunk
Hardware: PC Unknown
: P2 Normal
Target Milestone: 4.11.0
Assignee: Bugzilla mail exporter
URL:
Keywords:
Depends on:
Blocks: 3523
  Show dependency treegraph
 
Reported: 2019-10-31 12:30 CET by Pierre Ossman
Modified: 2019-11-05 15:51 CET (History)
0 users

See Also:
Acceptance Criteria:


Attachments

Description Pierre Ossman cendio 2019-10-31 12:30:20 CET
Tested with Safari 13 on macOS 14. Chrome and Firefox do not have this behaviour.
Comment 1 Pierre Ossman cendio 2019-11-01 12:20:20 CET
Not sure who is in the right here. Apparently AltGr+space for non-breaking space is used in Linux in some cases as well.

Reporting to WebKit for now:

https://bugs.webkit.org/show_bug.cgi?id=203730
Comment 2 Pierre Ossman cendio 2019-11-04 13:01:34 CET
WebKit thinks they are doing things correctly and that Chrome and Firefox are buggy. So I've reported to them instead:

https://bugzilla.mozilla.org/show_bug.cgi?id=1593633
https://bugs.chromium.org/p/chromium/issues/detail?id=1021006
Comment 3 Pierre Ossman cendio 2019-11-05 15:50:36 CET
I can't reproduce this issue any more. I'm not sure what I was initially doing different.

Closing.

Note You need to log in before you can comment on or make changes to this bug.