Bug 7714 - tl-setup logs "Unknown transaction action 7" with DNF
Summary: tl-setup logs "Unknown transaction action 7" with DNF
Status: CLOSED FIXED
Alias: None
Product: ThinLinc
Classification: Unclassified
Component: Server Installer (show other bugs)
Version: trunk
Hardware: PC Unknown
: P2 Normal
Target Milestone: 4.13.0
Assignee: Pierre Ossman
URL:
Keywords: frifl_tester, relnotes
Depends on:
Blocks:
 
Reported: 2021-05-25 09:23 CEST by Pierre Ossman
Modified: 2021-05-26 16:01 CEST (History)
1 user (show)

See Also:
Acceptance Criteria:


Attachments

Description Pierre Ossman cendio 2021-05-25 09:23:49 CEST
I'm seeing a massive amount of these warnings when installing selinux-policy-devel on RHEL 8:

> 2021-05-24 17:08:15,854: Warning: Unknown transaction action 7
> 2021-05-24 17:08:15,854: Warning: Unknown transaction action 7
> 2021-05-24 17:08:15,854: Warning: Unknown transaction action 7
> 2021-05-24 17:08:15,855: Warning: Unknown transaction action 7
> 2021-05-24 17:08:15,855: Warning: Unknown transaction action 7

I have not dug out what action 7 is, but we really don't want all of this spam in the log.
Comment 1 Pierre Ossman cendio 2021-05-25 09:41:54 CEST
Apparently there has been some confusion around the exported callback constants in the Python API:

https://bugzilla.redhat.com/show_bug.cgi?id=1630113

7 is PKG_UPGRADED, but there seems to be others we don't handle as well.

The trigger seems to be an upgrade of DNF from 2 to 3, which might explain why we didn't notice this when we wrote the code.
Comment 2 Pierre Ossman cendio 2021-05-25 13:53:34 CEST
The issue seems to be that dnf has added special action types for the cleanup stages. Previously they would always be tagged as being "removed", but now they get more specific tags such as being "upgraded", or "reinstalled", or "obsoleted".
Comment 5 Pierre Ossman cendio 2021-05-26 11:09:11 CEST
Works well now. Instead of the unknown action I get a cleanup notice.


Note that it might not be possible to test anything other than an upgrade. I'm not sure there are any circumstances where the other actions are triggered by tl-setup.
Comment 6 Frida cendio 2021-05-26 16:01:28 CEST
I could reproduce on RHEL 8 and tl-4.12.1. When upgrading to build 2101, the warning is indeed gone. Only tested when a package needed upgrading as mentioned in comment 5.

Note You need to log in before you can comment on or make changes to this bug.