www.cendio.com
Bug 2426 - Multi-head via RANDR 1.2
: Multi-head via RANDR 1.2
Status: CLOSED FIXED
: ThinLinc
VNC
: pre-1.0
: PC Linux
: P2 Enhancement
: 4.0.0
Assigned To:
:
:
: 1527 2043
: 14
  Show dependency treegraph
 
Reported: 2007-03-20 08:21 by
Modified: 2012-11-28 12:06 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2007-03-20 08:21:24
This bug is about supporting the new way of doing multi-head, via RANDR 1.2.
(The old way being Xinerema)
------- Comment #1 From cendio 2007-03-29 14:25:31 -------
Rough time est.

This bug shouldn't be difficult considering both Xinerama and basic RANDR is in
place, and we have only one output per CRTC.
------- Comment #2 From cendio 2009-03-20 16:00:04 -------
We need to have a look at RandR 1.3 and see if panning is something that we
want for VNC.
------- Comment #5 From cendio 2012-07-13 12:52:39 -------
Clarification: This bug is about the server portions. Client is handled in bug
4229.
------- Comment #6 From cendio 2012-07-13 13:00:13 -------
Implemented in r25475.

Tester also needs to check that old clients still work.
------- Comment #7 From cendio 2012-07-18 13:18:27 -------
More outputs than necessary are being created. Need to have another look.
------- Comment #8 From cendio 2012-07-18 14:48:14 -------
This is caused by how Gnome disables outputs. It not only removes the mode, but
also the associated CRTC. This confuses our code.
------- Comment #9 From cendio 2012-07-18 16:53:57 -------
Fixed in r25510.
------- Comment #10 From cendio 2012-07-20 13:29:46 -------
We're doing something that upsets xfce's configuration tool. Need to have a
look.
------- Comment #11 From cendio 2012-08-27 14:35:32 -------
I'm getting a bogus "invalid screen layout" when using the OS X client. Seems
to have something to do with very specific frame buffer sizes before and after
the resize.
------- Comment #12 From cendio 2012-08-27 15:07:59 -------
(In reply to comment #11)
> I'm getting a bogus "invalid screen layout" when using the OS X client. Seems
> to have something to do with very specific frame buffer sizes before and after
> the resize.

Fixed in r25655.
------- Comment #13 From cendio 2012-08-29 11:13:33 -------
(In reply to comment #10)
> We're doing something that upsets xfce's configuration tool. Need to have a
> look.

Must have been fixed along the way. Cannot get any problems with it now.
------- Comment #14 From cendio 2012-10-03 15:12:57 -------
I need some concrete testcases for this bug
------- Comment #15 From cendio 2012-10-09 09:39:38 -------
Be creative! You're supposed to out-smart the guy implementing the bug ;)

Some ideas:

 - Test various randr tools (e.g. gnome's, xfce's and kde's display tools)

 - Try various odd local monitor configurations and see that they are properly
represented on the server.

 - Reconnect and resize with various configurations to see that things
transition smoothly.

 - Look in xinit.log for randr related warnings/errors

 - Test an old client and see how things behave when moving back and forth
(e.g. reconnect to a multi-monitor session created by a new client)

 - etc.
------- Comment #16 From cendio 2012-10-09 13:43:05 -------
Tested different layouts on client side (seperated, overlapped, in any
direction) while connecting to a session, the session is successfully updated
with the new layout requested, however i one changes the layout on serverside
the client will not update its layout and therefore a mismatch will be
introduced..

See new bug: #4419
------- Comment #17 From cendio 2012-10-10 08:37:40 -------
Tested to connect against a session with multiple monitors with 3.4.0 client
which seems to work as expected, xrandr tells there is an additional VNC screen
which is not activated.
------- Comment #18 From cendio 2012-10-15 08:17:40 -------
I failed to test with 3 monitors (hardware issue) as per request, 
but i have done several attempts to make the server side break 
and failed. I'm closing hereby this bug.