www.cendio.com
Bug 3249 - tl-select-profile should be able to display intro even if single profile only
: tl-select-profile should be able to display intro even if single profile only
Status: CLOSED FIXED
: ThinLinc
Other
: 3.0.0
: PC Unknown
: P2 Normal
: 4.2.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2009-09-14 11:49 by
Modified: 2014-04-01 15:47 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2009-09-14 11:49:38
Currently, tl-select-profile doesn't display the welcome screen if there's only
one profile available. Härryda doesn't like this, and I also think this is
wrong behaviour.
------- Comment #1 From cendio 2009-09-14 11:50:44 -------
Created an attachment (id=344) [details]
Suggested change to tl-run-rdesktop

See also discussion in komintern starting with article 337456. 
------- Comment #2 From cendio 2013-10-01 16:11:18 -------
*** Bug 4820 has been marked as a duplicate of this bug. ***
------- Comment #5 From cendio 2014-02-12 17:02:22 -------
Fixed in 28420.

Tester should make sure everything looks fine with the following combinations:

 - TLCOMMAND set, unset
 - PyGTK available, unavailable
 - 0, 1, >1 profiles
 - show_intro on, off
------- Comment #6 From cendio 2014-03-21 14:34:40 -------
(In reply to comment #5)
> Fixed in 28420.
> 
> Tester should make sure everything looks fine with the following combinations:
> 
>  - TLCOMMAND set, unset
>  - PyGTK available, unavailable
>  - 0, 1, >1 profiles
>  - show_intro on, off

Have tested most of the combinations using build 4298, works as expected.

Also xinit.log contains good information when things goes wrong such as when
PyGTK is not available.
------- Comment #7 From cendio 2014-03-28 14:01:17 -------
Quit button doesn't exit the session when using TLCOMMAND set.
------- Comment #8 From cendio 2014-03-28 14:01:56 -------
You get a "Next" button even if there is just one profile.
------- Comment #9 From cendio 2014-03-28 17:44:37 -------
(In reply to comment #7)
> Quit button doesn't exit the session when using TLCOMMAND set.

r28758

(In reply to comment #8)
> You get a "Next" button even if there is just one profile.

r28759
------- Comment #10 From cendio 2014-04-01 15:33:42 -------
(In reply to comment #9)
> (In reply to comment #7)
> > Quit button doesn't exit the session when using TLCOMMAND set.
> 
> r28758
> 
> (In reply to comment #8)
> > You get a "Next" button even if there is just one profile.
> 
> r28759

Tested using server build 4310.

Works as expected.