www.cendio.com
Bug 4070 - better http redirection for tlwebadm
: better http redirection for tlwebadm
Status: CLOSED DUPLICATE of bug 4580
: ThinLinc
Web Administration
: 3.2.0
: PC All
: P2 Enhancement
: 4.2.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2011-11-24 11:32 by
Modified: 2014-03-17 13:45 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2011-11-24 11:32:17
We implemented a basic redirection from http to https in bug 3842.
Unfortunately it will break under certain conditions:

- IPv6
- Proxying (will redirect to the wrong IP)
- With a proper certificate (it will mess up the URI, making the certificate
incorrect)

We should implement a more clever version that uses the Host: parameter it gets
from the browser to do the redirect.
------- Comment #1 From cendio 2014-02-21 16:15:21 -------
Bug 4580 is a dupe, but since we did most of the notes on the newer one I'll do
the duplicate marking the wrong way around.

*** This bug has been marked as a duplicate of bug 4580 ***