www.cendio.com
Bug 4461 - Upgrade to FLTK 1.3.2
: Upgrade to FLTK 1.3.2
Status: CLOSED FIXED
: ThinLinc
Client
: 3.4.0
: PC Unknown
: P2 Normal
: 4.1.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2012-11-07 08:47 by
Modified: 2013-05-30 15:50 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2012-11-07 08:47:45
FLTK 1.3.1 is out now. We should upgrade, then update the TigerVNC build
instructions.
------- Comment #1 From cendio 2012-12-03 09:27:36 -------
FLTK 1.3.1 has some serious bugs on OS X. We should wait for 1.3.2 instead.
------- Comment #2 From cendio 2013-01-22 09:38:17 -------
Fixed. We also switched to building FLTK with CMake, to match upstream. 

The tester needs to assert that the functionality of our add-on patches works
as expected.
------- Comment #3 From cendio 2013-01-29 08:45:26 -------
With the latest nightly build, the mouse cursor is never updated. I suspect the
FLTK upgrade.
------- Comment #4 From cendio 2013-01-31 14:09:51 -------
(In reply to comment #3)
> With the latest nightly build, the mouse cursor is never updated. I suspect the
> FLTK upgrade.

Bad CMake conversion. Fixed in r26476.
------- Comment #5 From cendio 2013-05-14 14:39:41 -------
vncviewer on Solaris is missing the FullScreenAllMonitors option.
------- Comment #6 From cendio 2013-05-16 12:56:05 -------
(In reply to comment #5)
> vncviewer on Solaris is missing the FullScreenAllMonitors option.

Weird. It is caused by this in the CMake test:

/usr/lib/gcc/sparc-sun-solaris2.10/4.5.3/../../../../sparc-sun-solaris2.10/bin/ld:
/usr/sparc-sun-solaris2.10/sys-root/usr/lib/libfltk_images.so: gethostname:
invalid version 8 (max 0)
/usr/sparc-sun-solaris2.10/sys-root/usr/lib/libfltk_images.so: could not read
symbols: Bad value

Which is some obscure binutils bug:

http://sourceware.org/bugzilla/show_bug.cgi?id=1021


Not sure why we are getting this now. Need to investigate further.
------- Comment #7 From cendio 2013-05-16 13:11:55 -------
Checking the build logs, it started failing with fltk 1.3.2-5 or 1.3.2-6 (no
build with -5, so not known which caused the problem). There had been at least
two intermediate (working) builds of FLTK using the latest binutils change
before that. So it seems like a change in our FLTK build triggered this.
------- Comment #8 From cendio 2013-05-16 14:57:26 -------
It was caused by us starting to build dynamic libraries with CMake, and they
were broken upstream (and still are). Fixed in r27395.
------- Comment #9 From cendio 2013-05-30 13:45:35 -------
(In reply to comment #2)
> The tester needs to assert that the functionality of our add-on patches works
> as expected.

Patch10: fltk-1.3.2-osx-10.4.patch:
Builds, so assuming good.

Patch20: fltk-1.3.x-cmake-fpic.patch:
Quick look at the patch seems to indicate we are building with -fPIC

Patch21: fltk-1.3.2-shared.patch:
Builds for Solaris, and http://www.fltk.org/str.php?L2962 seems to indicate
people are happy

Patch101: fltk-1.3.x-keyboard-x11.patch:
Tested dead_tilde from Ubuntu 13.04, works.

Patch102: fltk-1.3.x-keyboard-win32.patch:
Tested dead_tilde from Windows 8, works.

Patch103: fltk-1.3.x-keyboard-osx.patch:
Tested dead_tilde from OS X 10.4, works.

Patch201: fltk-1.3.x-clipboard.patch,
Patch202: fltk-1.3.x-clipboard-x11.patch:
Copy/paste of äöå works in both directions on Fedora 19.

Patch204: fltk-1.3.x-clipboard-win32-fix.patch,
Patch205: fltk-1.3.x-clipboard-win32.patch:
Copy/paste of äöå works in both directions on Windows 8.

Patch206: fltk-1.3.x-clipboard-osx.patch
Copy/paste of äöå works in both directions on OS X 10.4.
------- Comment #10 From cendio 2013-05-30 15:50:51 -------
Patch400: fltk-1.3.x-pixmap.patch:
Managed to get an hourglass on OS X

Patch401: fltk-1.3.x-cursor.patch:
Tried with Peter's "gold" custom icons, works like a charm

Patch700: fltk-1.3.0-modal.patch:
Everything is still nice and modal

Patch800: fltk-1.3.0-icons.patch:
Window icons look fine to me

Patch900: fltk-1.3.x-screen_num.patch,
Patch901: fltk-1.3.x-multihead.patch:
Multi-head still seems to work fine also.

Closing