www.cendio.com
Bug 4524 - Modifiers such as Alt_L gets stuck when using Alt-Shift-<, with certain layouts
: Modifiers such as Alt_L gets stuck when using Alt-Shift-<, with certain layouts
Status: CLOSED FIXED
: ThinLinc
VNC
: trunk
: PC Unknown
: P2 Normal
: 4.1.0
Assigned To:
:
:
: 4525
: 3523
  Show dependency treegraph
 
Reported: 2013-01-28 15:58 by
Modified: 2013-05-27 14:08 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2013-01-28 15:58:36
If you press the keyboard combination Alt, Shift, "<" (which is common in
Emacs), it sometimes happens that the Alt modifier gets stuck in the down
position. A single press on Alt_L releases it again. 

If you instead press Shift, Alt, "<" (it Shift before Alt), you get a ">"
symbol instead of the desired action (which is to go to the end of the
document).  

In both cases, the problem seems to be caused by Alt_L in two places in the
keyboard layout:

$ xmodmap -pke | grep Alt
keycode  64 = Alt_L Meta_L
keycode 204 = NoSymbol Alt_L

Removing any of them solves both problems above. Ie, it works with:

$ xmodmap -pke | grep Alt
keycode 64 = Alt_L Meta_L

but also:

$ xmodmap -pke | grep Alt
keycode 204 = Alt_L Meta_L

It could be that the code in Xvnc assumes that Alt_L can only be found in one
single location in the keyboard layout.
------- Comment #1 From cendio 2013-04-15 16:38:04 -------
Fixed as part of bug 3074. The new code makes sure to send the same keycode for
a given symbol. The old one could sometimes pick a different one, resulting in
a key left in a down state.
------- Comment #2 From cendio 2013-05-27 14:08:17 -------
Cannot reproduce this problem with the new implementation.