www.cendio.com
Bug 4548 - When CapsLock is active on the client, applications sees this as Shift+symbols
: When CapsLock is active on the client, applications sees this as Shift+symbols
Status: CLOSED DUPLICATE of bug 400
: ThinLinc
VNC
: 3.2.0
: PC Unknown
: P2 Normal
: 4.9.0
Assigned To:
:
:
: 400
: 3523
  Show dependency treegraph
 
Reported: 2013-02-27 13:05 by
Modified: 2018-04-23 13:31 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2013-02-27 13:05:29
Currently, the VNC protocol does not provide any synchronization of CapsLock.
When CapsLock is active on the client and the user presses, say, "j", this is
transferred as XK_J. On the server side, Shift will be "faked" if necessary.
CapsLock will never be activated. This means that applications cannot
distinguish between Shift-j and CapsLock-j. 

One example of when this is a problem is when activating full screen mode in
LibreOffice Writer. This is done with Ctrl-Shift-j. However, if CapsLock is
active on the client, you must use Ctrl-j instead.
------- Comment #1 From cendio 2013-02-27 13:08:13 -------
See also bug 400.
------- Comment #3 From cendio 2013-05-22 15:41:34 -------
For a 4.1 solution, we will need a XKB tool to activate CapsLock. This could
be:

* A modified version of numlockx

* xkbset, available from http://www.math.missouri.edu/~stephen/software/
------- Comment #4 From cendio 2013-05-27 10:25:32 -------
https://bugs.launchpad.net/ubuntu/+source/numlockx/+bug/218202 references
https://bugs.freedesktop.org/show_bug.cgi?id=16145 ; both are interesting.
------- Comment #5 From cendio 2013-05-27 10:41:10 -------
(In reply to comment #3)
> For a 4.1 solution, we will need a XKB tool to activate CapsLock. This could
> be:
> 
> * A modified version of numlockx
> 
> * xkbset, available from http://www.math.missouri.edu/~stephen/software/

It turns out that https://github.com/jordansissel/xdotool can do this. Thus, to
set Caps lock in the TL session, one can create a script in xstartup.d that
looks like:

#!/bin/sh
/usr/local/bin/xdotool.static key Caps_Lock
------- Comment #7 From cendio 2018-01-23 14:00:55 -------
Bug 400 has been fixed upstream, so this will be resolved with the next vendor
drop.
------- Comment #8 From cendio 2018-04-23 13:31:14 -------

*** This bug has been marked as a duplicate of bug 400 ***