www.cendio.com
Bug 4690 - Smartcard authentication support for Mac OS X client
: Smartcard authentication support for Mac OS X client
Status: CLOSED FIXED
: ThinLinc
Smart card
: 4.1.0
: PC Unknown
: P2 Enhancement
: 4.1.1
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2013-06-11 14:44 by
Modified: 2013-10-24 10:57 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2013-06-11 14:44:50
OSX client does support local smart card redirection but not authentication
using smart card. This is probably doable now on OSX platform.
------- Comment #1 From cendio 2013-07-18 16:38:03 -------
OpenSC fixed in r27703, Makefile.thinlinc-client in r27704 and tlclient in
r27705.
------- Comment #2 From cendio 2013-07-19 14:39:42 -------
*** Bug 3749 has been marked as a duplicate of this bug. ***
------- Comment #3 From cendio 2013-10-17 10:37:52 -------
Does not work:

2013-10-17T10:32:56: Log file created
2013-10-17T10:32:56: ThinLinc client release 4.1.0post build 4116
2013-10-17T10:32:57: Unable to load PKCS#11 modules '/Applications/ThinLinc
Client.app/Contents/lib/tlclient/opensc-pkcs11.dylib'
2013-10-17T10:32:58: Log file ended
------- Comment #4 From cendio 2013-10-17 14:27:58 -------
Improper testing on my part. It seems like Apple's strip has horrible defaults
and produces unusable files if applied to dynamic libraries. Will have to look
at how to handle this...
------- Comment #5 From cendio 2013-10-17 14:50:04 -------
Some more debug logging added in r28051 and the stripping fixed in r28052.
------- Comment #6 From cendio 2013-10-21 12:59:03 -------
Works great.