www.cendio.com
Bug 4752 - Unable to logout from 2003 WTS session when using alternative shell
: Unable to logout from 2003 WTS session when using alternative shell
Status: CLOSED FIXED
: ThinLinc
Sound
: trunk
: PC Unknown
: P2 Normal
: 4.1.1
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2013-07-15 11:58 by
Modified: 2013-10-24 11:02 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2013-07-15 11:58:15
Tested against eudemo.thinlinc.com:

/opt/thinlinc/bin/rdesktop -k sv efti.thinlinc.com -s notepad 

After closing the Notepad application, a gray background stays, and the WTS
session is not ended until I manually terminate the tlsnd.exe process for my
user. This only happens when using "-s"; a normal desktop works fine.
------- Comment #1 From cendio 2013-07-15 13:19:48 -------
This bug seems to be caused by tlsnd.exe no longer being marked as a sysproc.
In r18359, part of bug 3112, we lost this registry tweak:

-[Registry]
-Root: HKLM; Subkey: "SYSTEM\CurrentControlSet\Control\Terminal
Server\SysProcs"; ValueType: dword; ValueName: "tlsnd.exe";
------- Comment #2 From cendio 2013-09-12 16:00:23 -------
Fixed in 27877. I've tested on a 32-bit 2003 machine; tester should test on a
64 bit one.
------- Comment #3 From cendio 2013-10-17 10:53:03 -------
Apart from Windows taking ~40 seconds to figure out that notepad has been
closed, it works fine with the command given in the description, modified for
using my test WTS. Tested on 2003R2 x64.