www.cendio.com
Bug 4803 - Client support for Windows 8.1 and Windows 2012 R2
: Client support for Windows 8.1 and Windows 2012 R2
Status: CLOSED FIXED
: ThinLinc
Client
: trunk
: PC Windows
: P2 Enhancement
: 4.1.1
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2013-09-11 08:27 by
Modified: 2013-10-24 11:05 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2013-09-11 08:27:12
Windows 8.1 will be released on October 18. Sooner or later, the ThinLinc
client should support this platform.
------- Comment #2 From cendio 2013-09-23 11:27:19 -------
Sigh. Windows 8.1 has version number 6.3, but in most cases, GetVersionEX()
will report version 6.2 instead. From 

http://msdn.microsoft.com/en-us/library/windows/desktop/dn302074.aspx:

"The main cause of issues with changes to the operating system version was a
result of how developers performed version checking. However due to the poor
checks, the message would often show that the app needed to be run on XP or
later, which of course the newest OS is. More often than not, the newest OS
would run the app without any issues if it were not for these checks."

Their "solution" is also to deprecate GetVersionEx and introduce a new
VersionHelper Win32 API. Well, perhaps. The documentation is only preliminary
and only applies to the 8.1 preview. Sigh.
------- Comment #3 From cendio 2013-09-23 16:21:50 -------
Documentation and tlclient version check updated in 27941. Brief testing was
fine:

* Sound
* Local Drives
* Printing
* Smart card auth
* Smart card tunnel

Not tested on 2012R2 yet; can be done in test cycle.
------- Comment #4 From cendio 2013-10-11 09:13:00 -------
Tested ThinLinc client 4109 on Windows 8.1

> * Sound
Works as expected

> * Local Drives
Works as expected

> * Printing
Works as expected both with and without local printer dialog.

> * Smart card auth
Works as expected

> * Smart card tunnel
Works as expected
------- Comment #5 From cendio 2013-10-11 09:15:14 -------
I had one case were tlclient.log couldn't be renamed to tlclient.log.old and
this was NOT while the logfile was selected in a explorer view. Couldn't
reproduce this and I verified it during my tests and it worked as expected...
------- Comment #6 From cendio 2013-10-15 15:57:55 -------
Tested using client 4113 on Windows 2012 Server 64bit (Virtual machine).

> * Sound
Not tested

> * Local Drives
Works as expected

> * Printing
Works as expected.

> * Smart card auth
Not tested

> * Smart card tunnel
Not tested
------- Comment #7 From cendio 2013-10-15 16:03:59 -------
(In reply to comment #3)
> Documentation and tlclient version check updated in 27941.

Verified documentation.