www.cendio.com
Bug 4966 - Support for authenticating with Aventra MyEID Dual Interface PKI card
: Support for authenticating with Aventra MyEID Dual Interface PKI card
Status: CLOSED FIXED
: ThinLinc
Smart card
: trunk
: PC Unknown
: P2 Normal
: 4.2.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2014-01-22 09:33 by
Modified: 2014-04-02 09:03 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2014-01-22 09:33:47
We would like to support authentication with the Aventra MyEID Dual Interface
PKI card. What's missing is currently that our opensc-pkcs11 does not know
about the ATR. See:

https://www.opensc-project.org/opensc/ticket/440

However, instead if patching opensc.conf, we should add the ATR to the code.
This has actually been done "silently" in the upstream OpenSC project, as part
of another 2K line patch:

commit 457426543dfa02597895d57013dde94cc9e7d038
Author: sjoblomt <development@aventra.fi>
Date:   Wed Nov 28 12:52:43 2012 +0200

    MyEID ECDSA support

Will cherrypick instead.
------- Comment #1 From cendio 2014-01-22 09:36:58 -------
Fixed in 28326.
------- Comment #2 From cendio 2014-03-20 09:21:36 -------
Tested connection with card in a standard reader using client build 4294. Works
as expected.
------- Comment #3 From cendio 2014-03-20 09:24:47 -------
Tested using contact less reader in FC19 and client build 4294. Everything
works as expected.